iPad iTunes 12 Keeps quitting when I tried to upgrade to iOS 8 GM

Discussion in 'iOS 8' started by NYRob94, Sep 10, 2014.

  1. NYRob94 macrumors member

    NYRob94

    Joined:
    Jan 31, 2009
    Location:
    Long Island
    #1
    I have the Yosemite public beta 2 along with iTunes 12 installed on my mac. I tried to upgrade my iPad to the iOS8 GM and iTunes quit on me and now it won't open. On my iPad it does the connect to iTunes screen. What do I do??? Is there a way to get out of this or downgrade to iTunes 11?? Please help me!

    Thanks,
    Rob
     
  2. mattyb1978 macrumors newbie

    mattyb1978

    Joined:
    Sep 18, 2012
    #2
    I had the same problem. I actually had to us a computer (windows) with the current version 11 iTunes not the beta copy i was running on my mac. It worked that way without a problem
     
  3. NYRob94 thread starter macrumors member

    NYRob94

    Joined:
    Jan 31, 2009
    Location:
    Long Island
  4. Menel macrumors 603

    Menel

    Joined:
    Aug 4, 2011
    Location:
    ATL
    #5
    Don't use iTunes 12, it's beta, and unstable.

    You need to use your main system, on a release OS, with iTunes 11.3 or 11.4.

    ----------

    By all accounts in those threads, you've lost all data on your iPad.
     
  5. Cougarcat macrumors 604

    Joined:
    Sep 19, 2003
    #6
    A new beta just came out, BTW. Still doesn't work for me, though. I get a -1 error.
     
  6. NYRob94 thread starter macrumors member

    NYRob94

    Joined:
    Jan 31, 2009
    Location:
    Long Island
    #7
    still having issues

    I downgraded to iTunes 11. But when it tries to restore it i get this message:
     

    Attached Files:

  7. joeyp000 macrumors newbie

    Joined:
    Jul 9, 2013
    #8
    I had the same issue. It turned out I had a version of iOS 8 GM that was labelled for an iPad mini Retina but only was intended for LTE models when my iPad is wifi only.

    I looked up my model number and found that I had downloaded a model meant for a1490 when I needed to find the one meant for a1489.

    I suggest making sure you are using the correct install IPSW.
     
  8. Whtchdr macrumors regular

    Joined:
    Jun 14, 2013
    #9
    Make sure you have updated the beta of XCode 6.1to the latest. I had the same problem and once I installed that update, iTunes worked fine.
     
  9. KdParker macrumors 601

    KdParker

    Joined:
    Oct 1, 2010
    Location:
    Everywhere
    #10
    Also open the latest Xcode. This might take a bit to open.
     
  10. humar macrumors 6502

    humar

    Joined:
    Feb 17, 2012
    Location:
    Italy
    #11
    A couple of hours ago Apple released a new beta of iTunes 12.. Try with that or follow the "Xcode in background" solution.
     

Share This Page