iTunes artist a no show in iPhone music sync???

Discussion in 'iPhone Tips, Help and Troubleshooting' started by mcwrath, Dec 16, 2009.

  1. mcwrath macrumors newbie

    Joined:
    Dec 16, 2009
    #1
    When syncing my iPhone to the music on my iTunes, I choose to manually select the artists. (too much music in iTunes to fit on my iPhone 3GS 16gig)

    If I have Sarah Vaughan in my iTunes Music Library then I should be able to manually select that artist when I sync my iPhone.

    Not all artists in my iTunes music library, including Sarah Vaughan, show up in the Sync Music > Selected playlists, artists and genres > Artists section.

    Why is that?
     
  2. manuelfp macrumors newbie

    Joined:
    May 23, 2008
    #2
    Found solution: disable compilations

    You just need to disable compilation on info music.

    If you show music properties , find its location. The original folder isn't the artist folder. It is music > compilation > artist name
    That's why you can't sync to your iphone. I think it is an iTunes mistake.

    After disable the song as a compilation it will work correct.

    Let me know if this worked for you!
     
  3. prijecttimmy macrumors newbie

    Joined:
    Nov 25, 2011
    #3
    Attention!

    Here's the stitch.
    If you're still having the problem, here is the solution.

    iTunes allows you to edit the ID3 tag, but for some reason if there isn't already a title tag in the song, the title tag for that song in itunes becomes the FILENAME not the title tag.

    What you have to do is, manually edit the title tag on your computer or with an external ID3 tagger software, the title tag IS NOT the file name.

    In windows you can do this by; Right clicking the song, clicking properties and clicking details.

    Make sure to have written the 'Title' and 'Album Artist' tags, the rest don't officially matter as you can change them later through iTunes. You can also change 'Album Artist' in iTunes, but do this before as a precaution.

    No idea on mac as I don't use one lol.

    Then upload to your iPod or iPhone, and it will be solved.

    I hope this helps anyone, I have musical OCD and this really pissed me off.

    Thanks.

    - Timmy :)
     

Share This Page