iTunes errors 21, 1603 or 1604 when updating 4S from 5.0.1 to 5.1.1

Discussion in 'iPhone Tips, Help and Troubleshooting' started by King Mustard, May 25, 2012.

  1. King Mustard macrumors member

    King Mustard

    Joined:
    Oct 15, 2006
    #1
    I am attempting to update my jailbroken iPhone 4S from 5.0.1 to 5.1.1.

    If I click the Restore button, I get error 1604.

    If I shift-click on the Restore button (then use iPhone4,1_5.1.1_9B206_Restore), I get error 1603.

    I have:


    • Ensured I am running the latest version of iTunes
    • Restarted my PC (Windows 7 x64)
    • Tried to use a different USB port
    • Restarted the Apple Mobile Device service
    • Reset the iPhone sync history in iTunes
    • Booted into DFU mode before trying update
    Also, sometimes I get error 21.

    Any ideas?
     
  2. jpc1979 macrumors newbie

    Joined:
    May 25, 2012
    #2
    Use iReb

    download and use iReb --- works everytime for me
     
  3. GreenMonster13 macrumors newbie

    Joined:
    Apr 6, 2012
    #3
    Yeah, I'm getting the same error messages w/ a iPhone 4 GSM that I'm trying to restore to 5.1.1 from 5.0.1.

    Not sure what the deal is... Apple released another version of 5.1.1 (5.1.1_9B208) so I don't know if the signing window has closed for 5.1.1_9B206.

    I stitched my shsh blobs, but still no luck...

    Something funky is going on...
     

Share This Page