iTunes imports a 5 minute song as 36 minutes.

Discussion in 'Mac Apps and Mac App Store' started by cornerdealy, Jul 27, 2008.

  1. cornerdealy macrumors regular

    Joined:
    May 30, 2006
    #1
    There's nothing wrong with the song, I can play it in quicktime and quicklook just fine, but when i add it to itunes it becomes 36 minutes long. what the heck is going on?
     
  2. mrkgoo macrumors 65816

    Joined:
    Aug 18, 2005
    #2
    I think the question is - what is in the extra 31 minutes? does it loop? is it just noise, or silence?
     
  3. cornerdealy thread starter macrumors regular

    Joined:
    May 30, 2006
    #3
    i think it loops, but its hard to tell, i dont think it loops the whole song, just parts of it.

    it's weird. and when i open it in garage band it's only 5 minutes too
     
  4. cornerdealy thread starter macrumors regular

    Joined:
    May 30, 2006
    #4
    if anyone wants to check it out and see if it does the same thing for them, shoot me an email at cornerdealy@gmail.com and ill send it to you.

    (it's a free song, it's not pirated or anything)
     
  5. Lunchbox16 macrumors member

    Joined:
    Jul 28, 2008
    #5
    I have a similar issue with a few albums in my iTunes library. I got them from a friend and when I imported them to iTunes the time on some songs was much longer than the actual recording. For instance, a 6:30 song might show up as being 17:47 in duration. However, during playback, the song plays at it's normal length. I don't get it. Does the playback for you tracks continue until the 36min mark or do they play for the normal time, eschew the extra 29 minutes, and go onto the next song. If it's the latter (like mine) I wouldn't worry about it. I tried erasing and re-importing but it turned out the same. If it really bothers you I'd try re-ripping and encoding the track, assuming it's from a CD you own.
     
  6. gnasher729 macrumors P6

    gnasher729

    Joined:
    Nov 25, 2005
    #6
    I have noticed that with some free CDs; one or more songs having extra stuff added when you play them in iTunes. The creator of a CD can manipulate it so it plays fine on a CD player, but has extra stuff added in iTunes. To fix this while getting best quality:

    1. Switch to "Apple lossless" importing, then import the CD.

    2. Click on the songs that cause problem. Get Info, Options, then change "End Time" to the correct value. Play to the end of the song to make sure you didn't cut off too much or too little. When that is done, the 31 extra minutes are still there, but they won't be played anymore.

    3. Switch from "Apple lossless" to the quality you actually wanted to use, for example AAC. Select all the songs, then right click + "Convert Selection to AAC" (or MP3, or whatever you wanted). In the converted songs, the 31 extra minutes are completely and permanently gone.

    4. Select the "Apple lossless" songs and delete them.
     

Share This Page