iTunes/iPhone syncing has deleted 2 Photo folders from phone and wont restore them

Discussion in 'iPhone Tips, Help and Troubleshooting' started by dissembly, Jul 23, 2010.

  1. dissembly macrumors newbie

    Joined:
    Jun 19, 2010
    #1
    Hey all,

    I am running iTunes 9 (9.2.0.61) on a laptop with Windows XP. (Edited to add: the phone is a 3GS)

    I have a folder on my laptop where i sync my Iphone's photos, it has a collection of folders containing photos in there. When i sync those folders, they appear on my iPhone (irritatingly, when i sync only one of those folders, it deletes all other other ones... Apple logic is apparently not Palm/Panasonic/Samsung/Microsoft/AnybodyElseOnEarth logic. But never mind that).

    The other day i went to show someone pictures of my cat on my iPhone, and tried to browse to the appropriate folder under Photos, only to find that it was not there.

    I checked, and another folder had apparently been deleted from the iPhone. The other seven folders where okay.

    So i browsed to where the folders were kept on my computer. Apparently i had unthinkingly changed the name of the two folders that where now missing on the iPhone. Okay. So i must have had iTunes set up to sync individual Photo folders, and when i changed the names of those folders on the PC, it must have deleted them outright from the iPhone, right? Okay. Frustrating, and bad design for a syncing program, but easy to resolve.

    So i changed the names back. Made sure the right folders (i.e. every single folder i want on the phone) where selected under the Photos syncing tab in iTunes. Synced again - and nothing changed. Even though iTunes can see those folders, and allows me to select them for syncing, it will not upload them to the iPhone.

    Edited to add: I should mention, I have also tried to sync Photos "wholesale", by checking "All folders" rather than "Selected folders" - result is the same: nothing happens. It says it is syncing, but these two folders are still missing from my phone.

    So, i am not sure what to do. They're there, iTunes says they are there, but they don't turn up in the phone.

    Any ideas?


    ----------------------------------
    ranty aside: Also, what is the deal with Itunes syncing in general? More than a decade of user-friendly PDA and mobile phone syncing programs from multiple different developers that would just do what you told them to do, with no ambiguous commands, no random deletes, actual syncing (where updates on the computer and on the device are both taken into account in intelligent ways), but then Apple comes out with Itunes...? Why is it the way it is? :( I do not understand. Non capisco.
     
  2. dissembly thread starter macrumors newbie

    Joined:
    Jun 19, 2010
    #2
    Wut.

    More information: Since posting the above, i re-named the folder that the files originally came from, and had iTunes treat it as if i was using a totally new folder full of totally different pictures.

    Sync photos from -> choose folder... -> browsed to re-named folder.

    The sync this time took much longer than before, and so i thought, "Oh wow! it's just doing it al from scratch! Problem solved."

    And yet, nothing is different. My iPhone supposedly just synced with what it thought was a whole new folder, and somehow it has only downloaded exactly the same few folders it already had from my laptop.

    -----------------------------

    Edited to add solution:

    I also noticed that i had blacked out non-existent "pictures" taking up slots in my Camera Roll. I didn't think these issues were related, but after i deleted everything in the camera roll and removed the blacked out non-existent "pictures", the phone synced normally and my folders appeared!
     
  3. dissembly thread starter macrumors newbie

    Joined:
    Jun 19, 2010
    #3
    Okay - i am now having this exact same problem again.

    Following what i did above - deleting the "blacked out" non-existent images from the camera roll - is not wrking this time.

    It is as if the Photos program's directory of albums is not refreshing.

    Does anyone have an actual fix? (Or any clue as to how it must have fixed itself the first time?)

    I have yet to find any satisfactory solution to this bug.

    Any ideas?
     

Share This Page