iTunes: Problem with Special characters (e.g. ä, ö, ü, ß) in Movement Name tag

Discussion in 'Mac Apps and Mac App Store' started by caaalebbb, Sep 21, 2016.

  1. caaalebbb macrumors member

    caaalebbb

    Joined:
    Mar 15, 2011
    #1
    [I'm using an early 2015 Macbook retina with Sierra with iTunes 12.5.1.21, but I had the following problem with El Capitan as well]

    Special characters (e.g. ä, ö, ü, ß) display as "�" or "?" in (only in) the Movement Name tag—there is, however, no such problem in the song name tag.

    Just one example (though any track with special characters has this problem), here is a name of a piece:

    Slavonic Dances, Op. 46: No. 5: Skočná: Allegro vivace​

    I want to utilize the new Work/Movement feature (rather than the mere "Grouping" feature). So I set the work as:

    Slavonic Dances, Op. 46​

    and I set the movement to 5 (of 8), and I set the name to

    Skočná: Allegro vivace.​

    This works when I manually enter the track name. But if I right click the track and go to "get info", the movement name reverts to:

    Skoc�n�: Allegro vivace​

    Or, if I simply play the track, the movement name changes to:

    Skoc?n?: Allegro vivace​

    No such problem occurs with, for example, the album tag (if the album title has special characters) or the song name tag. I've confirmed I'm not alone in this problem. Surely this is a problem. Is there a fix? If not, is there at least a way to report this?
     
  2. caaalebbb thread starter macrumors member

    caaalebbb

    Joined:
    Mar 15, 2011

Share This Page