iTunes Will not add/play music its played in the past

Discussion in 'Mac Apps and Mac App Store' started by aceman67, Jan 18, 2009.

  1. aceman67 macrumors newbie

    Joined:
    Jan 18, 2009
    #1
    I've run into an odd problem where iTunes (v8.0.2.20 Windows Vista) will not add, play or do anything with audio files (mp3) that it has previously played in the past (same version of iTunes). It played it one day, then the album disappeared and will not allow it to be added again, it does how ever work perfectly in Quicktime player, Winamp, WMP and other players.

    When I use Add Folder to Library, I get a quick "Processing files" dialogue, then it disappears (Same if I drag the folder into the library itself), and when I try to play the files individually, nothing happens at all.

    I've tried everything short of reencoding the files, which I want to save as a last resort (So as to not lose audio quality) and Ripping the CD again isn't an option since I no longer have the original after my car was broken into.

    Help a poor guy out :(
     
  2. aceman67 thread starter macrumors newbie

    Joined:
    Jan 18, 2009
  3. Terryox macrumors newbie

    Joined:
    Feb 1, 2009
    #3
    Heh, I registered just to post here. I am having the same exact problem. I googled it to death and I have found several others as well, as far back as 2006, and no solutions. People either had to go and re-import/download the songs, or they just ended up losing everything on their harddrive due to some sort of failure anyway.

    This isn't the first time it's happened to me, but the last time it happened I just deleted the files and got them again from the same place as before. For now I can just use Winamp or WMP, but the rest of my family is very stubborn about the programs they use, so I'd like to know how to fix this in case it happens to them as well.
     

Share This Page