iTunes won't 'see' iTunes Music songs... any advice?

Discussion in 'Mac Apps and Mac App Store' started by malch, Mar 18, 2008.

  1. malch macrumors 6502

    Joined:
    Jan 20, 2008
    #1
    Hi there,

    I've dragged my old 'iTunes Music' folder (it's been stored on an external fw drive) to where it probably wants to go, onto my MBP hd (home folder/Music/iTunes/iTunes Music), and I've gone to iTunes Preferences/Advanced, and made it aware of this folder's placement, and then gone to 'Consolidate' in the Advanced menu... but then when I launch iTunes... nothing shows up.

    It seems I have to go (via Finder) into the folders nested within my iTunes Music folder, and double-click on each song... at which point, that song pops up in the iTunes window, and is then there for good.
    But I've got thousands of songs... I hope I don't have to do this to each one!

    Can someone tell me what I'm doing wrong? Why won't iTunes simply see all these songs in the iTunes Music folder??? (is it because they're inside other folders within this iTunes folder?)

    Thanks for any help,
    malch
     
  2. Peace macrumors Core

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #2
    You need the iTunes Library and XML files in the new folder too.

    Also make sure in iTunes preferences you have selected the proper location.
     
  3. malch thread starter macrumors 6502

    Joined:
    Jan 20, 2008
    #3
    O.K., right now the folder-structure is this:
    home folder/Music/iTunes/iTunes Music

    The last folder (iTunes Music) is full of folders (most of them with the name “composed by...”), which contain folders, that contain the .mp3 files.

    My XML file is in the 'iTunes' folder, along with the 'iTunes Music' folder; also in here is an 'iTunes Library' file, and a folder called 'Album Artwork'.
    Is this all as it should be, or should I move my iTunes Music Library.xml file into the 'iTunes Music' folder?

    thanks for helping,
    Malcolm
    Are you telling me
     
  4. malch thread starter macrumors 6502

    Joined:
    Jan 20, 2008
    #4
    I see this has a checkmark next to it, but my problem is ongoing - - I still have the issue I described above.
    Can someone advise... or at least tell me how to remove the checkmark, so people know my question hasn't been answered?
    Thanks,
    malch
     
  5. seeker777 macrumors member

    seeker777

    Joined:
    Oct 15, 2007
    #5
    My "iTunes Music Library.xml", "iTunes Library file", and "Album Artwork" are all in the iTunes Music folder.

    Also, the check mark just means that you have posted in the thread, and will appear next to other threads in which you make a post.
     
  6. malch thread starter macrumors 6502

    Joined:
    Jan 20, 2008
    #6
    Thank you Seeker for your note.
    I just discovered my problem, by the way - - what I had to do, as well as moving all the folders into the right places, was choose the 'Add to Library' command from the File menu. Solved the problem. Now I wish I could put that checkmark next to this post... Problem solved.
    cheers,
    malch
     

Share This Page