iWork Not Opening ANY Of The Files I'm Trying To Open

Discussion in 'Mac Basics and Help' started by OnAirNow, Jun 12, 2010.

  1. OnAirNow macrumors newbie

    Joined:
    Apr 16, 2010
    Location:
    Scotland
    #1
    Hi,

    I'm not sure if I'm doing something wrong, but so far none of the MS Word or Excel files I've tried to open with iWork will actually open. I expected a degree of compatibility issues but I thought the files would at least open even if the formatting went a bit off.

    I've tried .doc and .docx files and Pages just flashes up the 'file could not be opened' message.

    Its not a major headache at the moment - I know I can get free Open Office or wait for the new MS Office for Mac - its just from what I had read about iWork I expected at least some of the files to open. The one thing all the files have in common is embedded logos... could this be causing the issue?

    As always, thanks for your help.
     
  2. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    I doubt it has to do with embedded logos. Whether you have had iWork installed for a while or installed it recently, for starters, you should check for updates for Pages, Numbers through Software Update. iWork (for '08 and '09) file compatibility starts with Office 2003/2004 and later.
     
  3. PeggyD macrumors 6502a

    Joined:
    Jan 9, 2007
    Location:
    Covington, WA, USA
    #3
    Could the problem files be password-protected? The iWork apps can't open password-protected Office files. You'll have to use Office or one of the Office clones.
     

Share This Page