JailbreakMe is saying that my iPad 2 is not compatible but I'm on 4.3.3

Discussion in 'iPad Hacks' started by JJBro1, Aug 10, 2011.

  1. JJBro1 macrumors regular

    Joined:
    May 17, 2009
    #1
    I bought my iPad yesterday at best buy. Today I tried to jailbreak it through jailbreakme.com but it says my iPad is incompatible. I'm on 4.3.3 so what gives?
     
  2. Dingchow macrumors newbie

    Joined:
    Jul 4, 2011
    #2
  3. JJBro1 thread starter macrumors regular

    Joined:
    May 17, 2009
    #3
    I don't know what u mean by version but it's an iPad 2 on 4.3.3 8J2. I just tried it on my roomates ipad2 and he has the same firmware and it worked for him. Could it be that the new iPads are being shipped with the PDF exploit patch?
     
  4. Dingchow macrumors newbie

    Joined:
    Jul 4, 2011
    #4
  5. JJBro1 thread starter macrumors regular

    Joined:
    May 17, 2009
    #5
  6. dfweyer macrumors newbie

    Joined:
    Jan 30, 2010
  7. ZZ Bottom macrumors 6502a

    Joined:
    Apr 14, 2010
    #7
    I received a similar issue on my iPhone running 4.3.3. I was able to get it to work after a second time completely shutting the phone off. ALSO clear your cookies/cache in safari.

    BTW I have found it doesn't work in many third party browsers like iCab and Atomic. So if you aren't using safari, just use that app for it.
     
  8. JJBro1 thread starter macrumors regular

    Joined:
    May 17, 2009
    #8
    It was my network. I was connected to PDAnet and for some reason it wouldn't let me jailbreak, but once I switched to a regular router everything was fine.
     

Share This Page