jailbroke 4.0... upgraded to 4.0.1... can't JB now?!

Discussion in 'Jailbreaks and iOS Hacks' started by jarrodtb, Aug 2, 2010.

  1. jarrodtb macrumors member

    Joined:
    Oct 29, 2007
    #1
    hi.... subject says it all... is it possible I somehow messed up the JB by upgrading to 4.0.1 AFTER the initial JB of an iPhone4? just helped a friend JB their phone with no error, and mine has failed maybe 50 times over the past few hours. safari crashes each time immidiately after the download completes. have tried clearing safari in settings, rebooting, and turning off pop up blocker...

    thanks for any help.
     
  2. BobboZR2 macrumors regular

    Joined:
    Jul 3, 2008
    #2
    I would try putting the phone into DFU mode, install 4.0.1, restore from backup, and try again. It should work.

    I had a jailbroken 3GS on 3.1.2 that was also unlocked that I was planning to sell. I wanted to sell it with 4.0.1 installed so I updated to 4.0.1 (erasing the previous jailbreak in the process). I then tried the jailbreakme.com jailbreak and it errored out over and over again. I put the 3GS into DFU restore mode, reinstalled 4.0.1, restored as new (in this case because I'm selling a blank phone), and tried the jailbreak again. It worked like a charm. Keep in mind that if you do the DFU restore you will need a sim card (not micro sim) to be able to reactivate the iPhone in iTunes. I used my girlfriend's Sim from her 3GS. If you don't have a Sim like that then I would suggest you don't do the DFU restore as I mentioned above.

    All I know is that the above method worked for me when it kept erroring out. I hope it works for you too.
     
  3. PR0SP3R macrumors newbie

    Joined:
    Jul 6, 2010
    #3
    I think you have to restore and lose all your personal media in the process. It's a pain in the ass because the iPhone, in all its glory, can not be read as an external hard disk drive. I'm sure there are some workarounds but sounds a bit daunting.
     

Share This Page