jailbroke Iphone 4 for the first time and unable to connect to my network, HELP

Discussion in 'Jailbreaks and iOS Hacks' started by workmanrj, Apr 7, 2011.

  1. workmanrj macrumors newbie

    Joined:
    Apr 7, 2011
    #1
    Hi All,

    I jailbroke my Iphone4 for the first time under 4.3.1 using the new Redsn0w. The jailbrake worked fine and installed cydia but was unable to connect to my network (Orange UK).

    My Phone is locked to Orange with the original sim installed, baseband is 04.10.01. I don't want to unlock my phone as I am under contract but would like to jailbreak to gain the advantages of the extra options through Cydia.

    Am I doing something wrong or can I not use the untehered jailbrak and still connect to my network?
     
  2. gooddeal macrumors regular

    gooddeal

    Joined:
    Aug 3, 2008
    Location:
    PA
  3. workmanrj thread starter macrumors newbie

    Joined:
    Apr 7, 2011
    #3
    Hi,

    Thanks for the reply. WIFI network is fine, it is my carrier Orange for phone and 3G that won't connect.
     
  4. stringent macrumors 6502

    stringent

    Joined:
    Jan 27, 2011
    Location:
    London
    #4
    Check your Orange data settings

    Settings -> General -> Network -> Cellular Data Network

    make sure these are correct.
     
  5. bigjnyc macrumors 601

    bigjnyc

    Joined:
    Apr 10, 2008
    #5
    Did you hacktivate? Sometimes this happens when you are on a legit iphone plan but choose to have the jailbreak tool activate the phone for you. If thats the case then the only solution is to restore and jailbreak again. This time make sure you unselect the activate phone option.
     
  6. workmanrj thread starter macrumors newbie

    Joined:
    Apr 7, 2011
    #6
    Hi stringent,

    When I tried to go into my carrier settings I got a message telling me "unable to download carrier list". Being new I panicked and just restored my phone through iTunes. I would like to have the jailbreak but need to be able to make calls more.

    Hi bigjnyc,

    I used the latest version of redsn0w for untethered jailbreak for 4.3.1. I followed the tutorial as linked to on the dev-teams blog site. Didn't see any options in Redsn0w offering to either activate or not activate my phone.

    Any further advice you guys can give would be appreciated.

    Thanks.
     
  7. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #7
    Did u activate the phone first thru iTunes before you ran redsnow?
     
  8. workmanrj thread starter macrumors newbie

    Joined:
    Apr 7, 2011
    #8
    Hi Applejuiced,

    I was running 4.3 on my phone and followed the redsn0w instructions to upgrade and jailbreak to 4.3.1. I didn't know if this was a common issue or if my phone could not be jailbroken if locked to a carrier.

    Is it worth trying again?

    Thanks
     

Share This Page