Japanese text showing up as little apples in Microsoft Word v. X for Mac

Discussion in 'Mac Apps and Mac App Store' started by Yofi, Jun 17, 2010.

  1. Yofi macrumors member

    Joined:
    May 25, 2009
    Location:
    Montreal, QC
    #1
    This is really frustrating me. I followed the instructions in the ReadMe for enabling Japanese for Office v. X (which you can find here http://support.microsoft.com/kb/821996 under Edit Japanese Text in Office Programs), and I know I did it right because there are Japanese options in the menus now (vertical writing, etc.), but when I try to type, the words go into a little pop-up input box I'm not used to, and then when I hit Enter they come up in the document as little apples mixed with random katakana (e.g. I'll type わたし and press enter and it'll look like イオ). I've tried switching the font to a Japanese one but it doesn't help…in fact, it reverts to Times as soon as I start typing again.

    I scoured the "mactopia" help forums for this and only found one other report of the same problem...all the other resources I've found just repeat the instructions I found in the ReadMe.

    Please help me out if you can! As a Japanese student, I'd really like to be able to use Japanese properly in Office.

    Thank you!
     
  2. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #2
    Is it perhaps the font you're using in the document? Have you tried creating a new document and also editing existing ones to see if the problem persists? I don't have Office so can't test.
     
  3. Yofi thread starter macrumors member

    Joined:
    May 25, 2009
    Location:
    Montreal, QC
    #3
    When I highlight text and change the font to a Japanese font, it's still apples (I've tried several fonts). I've also tried opening new documents and immediately changing the font to a Japanese one, but every time it gives me apples and immediately goes back to Times.
     
  4. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #4
  5. Yofi thread starter macrumors member

    Joined:
    May 25, 2009
    Location:
    Montreal, QC
    #5
    Yeah, I saw that site too. It's yet another site just telling me to do the same thing the ReadMe tells me to do. :( Thanks though!
     
  6. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #6
    Does this happen in any other application, such as using TextEdit to open the doc? Also make sure to try to use the same exact font choice in the other app. What's the specific Japanese font you're trying?

    Another thing to check, in Font Book, go to the font you're using and see if it's display correctly there.

    What happens if you write the Japanese in another doc and copy and paste it into something like TextEdit, and vice-versa?
     
  7. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
  8. Yofi thread starter macrumors member

    Joined:
    May 25, 2009
    Location:
    Montreal, QC
    #8
    Well this is interesting. When I copied and pasted the buggy Microsoft Word script into TextEdit, it stayed buggy in any font, although the random katakana interspersed with the apples changed fonts correctly. Then I tried writing with the default TextEdit font in TextEdit, which is apparently called Hiragino Kaku Gothic Pro, and copied the text from TextEdit to Microsoft Word, and it actually showed up, and then when I went through Japanese fonts, it changed correctly! However, when I try to continue to write in Japanese in Word in that same font, it shows up as boxes with random katakana mixed in.

    I tried copying some text from Wikipedia and pasting it in Microsoft Word and it showed up as 00 0オ00ノ0ワ0テ0ッ0ケ0g}. So it looks like Japanese will show up in Word only if it's copied from Word or TextEdit, and not when it's typed in Word, typed in an entry box (I copying some Japanese from my Google search box), or copied from the internet.
     
  9. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #9
    Seems like the encoding is getting screwy somewhere along the way. Not sure why though and I don't have Office to tinker with. For the time being you can sue TextEdit or download OpenOffice for your typing Japanese needs. The only other option is to reboot or to try the font validation mentioned above.
     

Share This Page