Joining Windows Networks annoyances

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by mainstreetmark, Nov 4, 2003.

  1. mainstreetmark macrumors 68020


    May 7, 2003
    Saint Augustine, FL
    So, my friends give me a bit of respect for being able to join their networks much, much faster than they can hook their own computers up ("Which workgroup, now? It wants me to create a new network...")

    But, here's the goofyness:

    - The Finder doesn't always list all the workgroups. I understand it has to discover them, but I can't TELL that it's discovering them. The little 'working swirl' would be appropriate.
    - Even if I add a un/pw to a keychain, I always have to type it in when re-connecting. The dialog defaults to my current username, vs what I used last ("administrator") and it doesn't remember the password.
    - Sometimes, when I disconnect from the network and leave, a while later, I'll get a series of warnings asking me to disconnect. The machines are clearly no longer reachable, so I would obviously want to disconnect. The dialogs feel intrusive, especially since it asks like 3 times.

    Anyone having similar experiences or any solutions?
  2. Schiffi macrumors 6502a


    May 22, 2003
    Same here on a campus network

    wait for 10.3.1 I say...
  3. Chad4Mac macrumors 6502

    Apr 20, 2002
    Los Angeles
    I'm having the same issues connecting to our Windows networks -- the "is it doing anything" while trying to connect to the network, the U/P thing, and, most definitely, the disconnect messages.

    What a pain in the arse these things are!

    I'm having problems understanding how to disconnect from the server. In Jaguar, a disk would mount to the desktop, and when I wanted to disconnect from the disk I threw it away -- real simple. However, in Panther, I'm really not sure how to "really" disconnect. I see and use the eject button next to Network, but I still get the "disconnect" messages.

    What am I doing wrong here?

  4. Balin64 macrumors 6502a


    Jul 23, 2002
    In a Mauve Dream
    You have to enter Long Name

    The Netrwork incon in the new side bar automatically finds PC's and servers nerar you. But, they are all aliases: ig you click the connect button underneath the alias icon, you get the user/password box, you enter them, and you are connected. But when you try to disconnect or eject the SMB mount (AFP works fine) it never does. And yes, you will get that annoying message everytime.

    I found this works: when you get the error message after disconnecting ethernet cable or turning off airport, it wilkl say something like "The server smb://USERNAME@SERVER/SMB Name is no longer available..." Use that protocol to connect next time: Instead of using the Network icon in Side Bar, from the finder use Apple+K. In the address bar, enetr the smb's path. Add it to your list, tehn click connect. After entering login info in next screen, the SMB mount will now appear in the side bar, and it can be ejected successfully. Hope that helps...
  5. monkeydo_jb macrumors 6502

    Apr 17, 2002
    Columbia, MO
    Have you tried adding the workgroups under- Applications-Utilities-Directory Access (or something like that)?

    I did this at home, and now the Windows workgroup in my apartment appears instantly.

    I'm at work, or I'd give more exact instructions.

  6. Chad4Mac macrumors 6502

    Apr 20, 2002
    Los Angeles
    Thanks for your help you guys. Much appreciation.

    I don't have a problem seeing our domain our server, drives, folders, etc. I have a problem knowing how to eject/terminate the connection so I don't get those disonnect messages. I could go into the directory access thingy, but I like the network there in the finder, and I'm not all that comfortable with it. I wish there is a way to disconnect the network -- in the finder -- so I don't get these disconnect messages.

    Actually, a new problem has come up. After I successfully connect to the server, the files that once looked like networked drive look like folders now, and there is nothing in them. I used to access this drives and shared files back and forth between my Mac and Windows SBS -- worked great. Now they are just folders. Weird.

    For now, I'm just connecting to my shared folders on the windows PC instead of conencting to the server to access the drives. Kind of a pain though.

    I hope there is a fix for this soon....

  7. notkevin macrumors member

    Mar 26, 2003
    Re: Joining Windows Networks annoyances

    I had this problem with 10.2 also. When I added my OSX username to the windows computer then it worked fine. It seems like the keychain is only storing the password and not the username.
  8. brutus macrumors member

    Oct 1, 2003
    similar problem

    i have a similar problem while connecting to my windows pc with panther. under jaguar everything worked perfect but since panther i dont even see see shared drives and folders. at work we have linux file server to which i can connect instantly. here at home: nothing. if i try apple/k and type in the ip i get an error message about not being able to connect to samba although samba is activated in my settings. in the finder i dont see any drives, even after waiting a while. both, the pb and pc are connected over a dsl combo switch and both can connect the internet perfectly. they just dont see each other...

  9. brutus macrumors member

    Oct 1, 2003
    problem solved!!!

    problem solved. different to jaguar one have to type smb://x.x.x.x to connect while with jaguar x.x.x.x was sufficent. even if the folder is not shown in the finder you can connect afterwords.
  10. ITR 81 macrumors 65816

    Oct 24, 2003
    Brutus I have friend with similar problem he can't see the PC's for file sharing but the PC's can see each other.

Share This Page