just bought used 3gs.. safe to erase all & update if I intend on unlocking it?

Discussion in 'Jailbreaks and iOS Hacks' started by topofthetrees, Jan 20, 2011.

  1. topofthetrees macrumors newbie

    Joined:
    Jan 18, 2011
    #1
    I just bought a used iPhone 3gs that I'd like to restore to the factory settings.
    Is it safe to erase & update using iTunes if I intend on unlocking it to use on T-Mobile?

    It currently uses 4.1 & 06.15.00.

    Any and all advice is appreciated.

    ETA- Also, the seller negelected to tell me his passcode to reset using the Settings menu.. so until he gets back to me (if/when), I'm kind of stuck :/ ..unless I can bypass that somehow?
     
  2. topofthetrees thread starter macrumors newbie

    Joined:
    Jan 18, 2011
    #2
    update

    current situation-

    I mistakenly tried to erase & restore it to factory settings when the unthinkable happened.. you guessed it- error 1501. I've tried for the better half of 7 hours to fix this. Several youtube videos and this tutorial later, I'm still stuck. Any tips/advice?

    Also, with that tutorial I linked to.. it said to download redsn0w, which I did.. but when I go to open it all that comes up is a text file with code. I think if I can fix that, I'll have a better shot at fixing my iPhone.

    I'm not too sure of the phones specifics, but it was on baseband 6.15, and I think firmware was 4.1(not certain).

    Any and all help would be greatly appreciated.
     
  3. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #3
    You forgot the link :)
     
  4. topofthetrees thread starter macrumors newbie

    Joined:
    Jan 18, 2011
    #5
    so everything's been restored. my problem with redsn0w was remedied by using my girlfriends pc instead of my mac.

    next issue- how do i activate it without an at&t sim? i only have a t-mobile sim.. :/
     
  5. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #6
    IIRC, you can use a pay as you go SIM. I don't remember if it needs to be active or not.
     
  6. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
  7. topofthetrees thread starter macrumors newbie

    Joined:
    Jan 18, 2011
    #8
    So it's activated now, which I did using redsn0w. Next issue- I can't jailbreak it. I've tried using both redsn0w and greenpois0n. redsn0w gets stuck mid jailbreak at the "loading ramdisk" portion. greenpois0n seemed to work, but once it finished the iPhone showed no signs of being jailbroken(no Cydia or similar installed). Any suggestions?


    As a reminder, my iPhone is 32gb 3gs. custom ipsw- 4.2.1(8C148a) / 6.15.00.



    Thanks, guys!
     

Share This Page