Just did newest Bluetooth update and now "No Airport Card Installed" (Unibody 1G MBP)

Discussion in 'MacBook Pro' started by Winstonp, Jun 20, 2009.

  1. Winstonp macrumors 6502a

    Winstonp

    Joined:
    Jan 2, 2005
    Location:
    Boston
    #1
    System: 2.4GHZ 15" MP Unibody

    Issue: I Just did the recent Bluetooth update and now "No Airport Card Installed" is all I see when I select the Airport "fan".

    My take: Not 100% sure wether the BT update and the wireless problem are related. However, it's annoying. In bootcamp, Windows XP shows a working card. I tried resetting the system prefs, in the process reseting PRAM, then I'll do Time machine restore (if needed) , then re-install (if needed), then clean install...

    Anyone seen this issue and know an exact remedy?

    Thanks
     
  2. iBookG4user macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
    #2
    If you go to "about this Mac" and then "more info", what does it say under AirPort Card?
     
  3. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #3
    It should be listed in System Profiler since it works in Windows.

    Go to Macintosh HD/Library/Preferences/SystemConfiguration and drag the file com.apple.airport.preferences.plist as well as preferences.plist to the trash. Enter in your password and check to see that those two files have been deleted. Restart your computer and post back with results.
     
  4. Winstonp thread starter macrumors 6502a

    Winstonp

    Joined:
    Jan 2, 2005
    Location:
    Boston
    #4
    "No information found." :( Yeah, checked there.
     
  5. Schtumple macrumors 601

    Schtumple

    Joined:
    Jun 13, 2007
    Location:
    benkadams.com
    #5
    My mate installed the update and had this problem (White polycarb MB), restart and it should be fine.
     
  6. JamesGorman macrumors 65816

    JamesGorman

    Joined:
    Dec 31, 2008
    Location:
    Winnipeg
    #6
    After I updated, my macbook told me that a bluetooth device was not present. This happened to me too, even before the update. It didn't even show the lil bluetooth icon in the menu bar. A restart fixed this both times, but still, it was a little concerning.
     
  7. Winstonp thread starter macrumors 6502a

    Winstonp

    Joined:
    Jan 2, 2005
    Location:
    Boston
    #7
    Oops! I forgot preferences.plist. That did the trick. Thanks for the help.
     

Share This Page