Just got my iPad2, have a question about iCal and iMessage

RonDeGregorio

macrumors member
Original poster
Jul 20, 2011
34
0
Hey all,
Just got my first iPad!

When I get/send imessages on my iphone, they don't get pushed to my iPad. Any ideas of what I have set up incorrectly?

Secondly, my cal app wont seem to sync.

It shows that it has all of my cals from my Mac and exchange accounts checked, but nothing is showing up on my cal.

Any clues guys?

Thanks!
 

Zcott

macrumors 68020
Oct 18, 2009
2,302
46
Belfast, Ireland
Under iMessage settings on your iPhone, change the caller ID to your email address. The iPad can't receive messages sent to your phone number.
 

jtmav

macrumors member
Dec 15, 2007
76
0
Under iMessage settings on your iPhone, change the caller ID to your email address. The iPad can't receive messages sent to your phone number.
I believe you can set it up to receive at 2 addresses, 1-phone and 2-email address.

JTMav
 

RonDeGregorio

macrumors member
Original poster
Jul 20, 2011
34
0
Also, doesn't seem like that fixed it!

On the iPhone, my phone number is grayed out, like I can't remove it.
My email addresses are the same on the iPhone and iPad.

Not sure what the problem could be!
 

verwon

macrumors 68030
Jul 26, 2011
2,676
2
Seattle
Also, doesn't seem like that fixed it!

On the iPhone, my phone number is grayed out, like I can't remove it.
My email addresses are the same on the iPhone and iPad.

Not sure what the problem could be!
The person sending has to be sending to one of the emails you use with iMessage, for it to sync to your iPad. It will not work if they text your phone number.
 

RonDeGregorio

macrumors member
Original poster
Jul 20, 2011
34
0
But after they send it to my email, will it sync up if they should text my phone number?
 

TLewis

macrumors 65816
Sep 19, 2007
1,130
0
left coast, US
But after they send it to my email, will it sync up if they should text my phone number?
As everyone else is saying, no. iMessages sent to your phone number go only to your iPhone. No where else. Ever.

If you want messages to be sent to all of your devices, the iMessages must be sent to an email address that is listed below Settings->Messages->Receive At, and that email address must exist on all of your iOS devices. Also, if you have an iPhone, you should set the iPhone's iMessage Caller ID to be the same as your iPad/iPod touch (see Settings->Messages->Receive At->Caller ID). If you don't, iMessages from your iPhone and iPad/iPod touch will end up in two different conversation threads on your recipient's device, and any replies will go to only one of your devices, and not both. (Basically, everyone with both an iPhone and an iPad/iPod touch should do this.)

I'm tired of repeating all this, so go here: http://guides.macrumors.com/iMessage
 

DNAppleGold

macrumors 6502
Apr 9, 2009
312
36
iMessage iPad iPhone synch

Here is a good post. Two big keys.
1. In iphone seetings there are two places your need to put your Mac ID email. Recieve at AND caller ID. I missed callee ID for a while because it is sou counterintuitive.
2. Old message threads in your iPhone will still have the phone nimbler as caller ID. Thus you will need to either delete any old thread on your iPhone or star a new thread from your iPad. Yes this sucks. http://idarwindaily.wordpress.com/2011/10/14/sync-imessages-between-your-iphone-ipad-and-ipod-touch/