just upgraded to Leopard and iTunes won't find my music on external drive

Discussion in 'macOS' started by CultHero, Aug 22, 2009.

  1. CultHero macrumors 6502

    Joined:
    Mar 20, 2007
    #1
    I keep all my music, tv shows and movies on an external drobo that is connected to my airport extreme. I just opened iTunes and it is not seeing my music (at least not populating it) despite the location in preferences / advanced being the drobo. I have tried resetting it but nothing helps. I don't want to move the music onto the iMac I want to keep it on the drobo. What gives?
     
  2. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #2
    Is is iTunes fully updated? If so, reinstall it.
     
  3. VTECaddict macrumors 6502

    Joined:
    Sep 15, 2008
    #3
    You JUST upgraded to Leopard when Snow Leopard is literally right around the corner? :confused:
     
  4. CultHero thread starter macrumors 6502

    Joined:
    Mar 20, 2007
    #4
    Drobo is currently copying other files and folders over to my desktop so restarting is not available but iTunes does need updating. Just not sure why it wouldn't see the location when everything matches up in iTunes preferences
     
  5. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #5
    What you may want to consider, if after updating to iTunes 8.2.1 it still does not see the library, is starting iTunes with the option key held down and then manually re-selecting the folder on the Drobo which contains the iTunes Library.itl file.
     
  6. CultHero thread starter macrumors 6502

    Joined:
    Mar 20, 2007
    #6
    ok, I will try that although I don't have that exact file name. I have tried choosing just itunes music and that isn't working. The files I have under "Drobo External Drive" are :

    Album Artwork
    iTunes Library.xml
    iTunes Music
    iTunes Library Genius.itb
    iTunes Library Extras.itb
    iTunes Library
    Downloads
     
  7. CultHero thread starter macrumors 6502

    Joined:
    Mar 20, 2007
    #7
    ok, i have upgraded but it still isn't finding it. Any suggestions? All my music etc is intact in my drobo but for some reason iTunes isn't populating with it when I open it. It just stays blank.
     
  8. CultHero thread starter macrumors 6502

    Joined:
    Mar 20, 2007
    #8
    I may have figured it out. The library folder was right but the associations were not. I went to file and add to library and pointed that back to my library on my external and all the associations are being rebuilt. I hope this works. The files are being added to iTunes as I type.

    And I upgraded as I have a powerbook that will only go as far as Leopard so I needed the leopard for that. I will take the iMac to Snow Leopard later. I am also one of those why fix whats not broken guys and Tiger was a great OS that I used for a long time and was very familiar with.
     

Share This Page