KanaaN Mini DisplayPort to HDMI doesn't work on 2013 MBA but does for 2011 Air?

Discussion in 'MacBook Air' started by smileman, Aug 23, 2013.

  1. smileman macrumors member

    Joined:
    Oct 23, 2011
    #1
    This cable has worked well with my wife's 2011 air for ouputing audio and video through our Onkyo receiver:

    http://www.amazon.co.uk/KanaaN-Mini-DisplayPort-1080p-Cable/dp/B004M1PI6E/ref=cm_cr_pr_product_top

    However, I can't get it to work on my new 2013 Air. My Air's display will flash like other Air's do when you plug in a cable, or power on a receiver connected by cable to my Mac. But I can't see external speakers in System Prefs/Audio/Output. An no sound outputs.

    Both my wife's Air and mine are Thunderbolt so can anyone think of a reason for why this would work on hers and not on my 2013 Haswell air?

    Thanks.
     
  2. Boyd01 macrumors 68040

    Boyd01

    Joined:
    Feb 21, 2012
    Location:
    New Jersey Pine Barrens
    #2
  3. smileman thread starter macrumors member

    Joined:
    Oct 23, 2011
    #3
    Ok, sounds like I'll need to visit the Genius bar to investigate.
     
  4. Boyd01 macrumors 68040

    Boyd01

    Joined:
    Feb 21, 2012
    Location:
    New Jersey Pine Barrens
    #4
    Does it still work with the 2011 MBA? Going to your Amazon link, the "most helpful critical review" says

    Are you sure the Thunderbolt port is working on your MBA? Do you have any Thunderbolt disks? Or a miniDisplayPort adaptor you can try with a DVI monitor?
     
  5. smileman, Aug 26, 2013
    Last edited: Aug 26, 2013

    smileman thread starter macrumors member

    Joined:
    Oct 23, 2011
    #5
    Yes, the cable still works perfectly on the 2011 Air for outputting sound.

    Unfortunately I don't have any other Thunderbolt/MiniDisplay Port cables or items to test my 2013 Air on.
     
  6. smileman thread starter macrumors member

    Joined:
    Oct 23, 2011
    #6
    Update

    Update: went to the Apple store and tested my 2013 Air using a Belkin cable and it worked fine. So that rules out my Air as the source of the problem.

    Kanaan tested the cable on one of their own 2013 Air's and it worked fine. So they kindly sent me a new cable and that still didn't work on the 2013 Air. But like the old cable is works perfectly on my wife's 2011 Air.

    So Kanaan decided to issue me a partial refund, which was nice of them as the old cable was well past warranty. But I really would like to know what the problem is?

    I would think if it was a software issue it likely would have also affected the Belkin cable I tested at the Apple store. It would seem incredibly odd if for some reason this cable was only doesn't work on my specific Air, right?
     

Share This Page