Keyboard and Mouse won´t load

Discussion in 'macOS' started by yoak, Nov 13, 2008.

  1. yoak macrumors 65816

    yoak

    Joined:
    Oct 4, 2004
    Location:
    Oslo, Norway
    #1
    I just got a new classic MBP 2.5 and I have one problem.
    When in System preferences and and try to open "Keyboard and Mouse", it just says; Loading Keyboard and Mouse. Then nothing happens and System Preferences freezes and i have to quit and re-open it to use it.

    Everything else in there works fine.
    I´ve tried to repair permissions as well
     
  2. blodwyn macrumors 65816

    Joined:
    Jul 28, 2004
    Location:
    Portland, Oregon
    #2
    Have you tried deleting the cache file?

    ~/Library/Caches/com.apple.preferencepanes.cache
     
  3. yoak thread starter macrumors 65816

    yoak

    Joined:
    Oct 4, 2004
    Location:
    Oslo, Norway
  4. yoak thread starter macrumors 65816

    yoak

    Joined:
    Oct 4, 2004
    Location:
    Oslo, Norway
  5. blodwyn macrumors 65816

    Joined:
    Jul 28, 2004
    Location:
    Portland, Oregon
  6. phatskis macrumors newbie

    Joined:
    Nov 13, 2008
    #6
    I'm having the same problem. Why does that cache file exist and will anything happen if I delete it. Thanks for the help. Mine isn't a new macbook pro but the 2.4 macbook pro that was released a few months before the recent update. I did however just recently do a fresh erase and re-install of leopard. Thanks for the help.
     
  7. yoak thread starter macrumors 65816

    yoak

    Joined:
    Oct 4, 2004
    Location:
    Oslo, Norway
    #7
    Hi Phatskis (twintip as well?)
    The problem re-occured just now.
    I have the same MBP as you, just faster CPU.

    Now I tried to delete the files again, but it keeps happening.
    I can´t do a clean re-install right now as I need a new HD to do a full back up.
    It seems that the cache files ends up outside the cache folder, could this cause the problem?
     
  8. phatskis macrumors newbie

    Joined:
    Nov 13, 2008
    #8
    Yes, I like my skis fat and with turned up tails.

    I found this thread on a apple support page. Here's the link:

    http://discussions.apple.com/thread.jspa?messageID=8078607

    I haven't had time to try any of the suggestions, but they look helpful. Any one else have any solutions for this problem?
     

Share This Page