Keyboard Problem!

Discussion in 'Macintosh Computers' started by iChan, Dec 11, 2003.

  1. iChan macrumors 6502a


    Jan 12, 2003
    Dublin, Ireland.
    Hello everyone! I need some help...

    I replaced the HD in the 12-inch powerbook today (7K60 7200RPM 60GB if you want to know, very quiet & fast!!! - it's freakin' shweet)

    I then formatted the drive and installed the DVD that came with brother's 15-inch Powerbook that contains Panther. (I only had Jagwire)

    Now, here is the problem...

    after installing the OS onto the HD, some of the keys do not work anymore!

    well, the work, but do really weird things!

    The following keys do not work...

    right arrow
    up arrow
    button to left of "1"
    button to left of "z"
    Media eject key
    button to right of "p"

    I am going to press each of the above keys in order to show you what i get back...


    in addition to this, some buttons also activate exposé!

    That's it!!! I don't have a clue what's going on... does the 15-incher and the 12-incher have different keyboards or something?

    what can I do?

    maybe someone can give the 12-incher's keyboard driver to replace the one I have?

    thanks a million everyone!

    sorry about the double-posting, that's the keyboard acting.

    PS: it seems strange that none of the 'standard' keys are affected like the letters are numbers...

    must be a driver problem...
  2. tibookrenegade macrumors newbie

    Dec 16, 2003
    same problem!

    ive been having the same problem... sleeping and waking my 15 inch ti is a temporary fix, so ive gotten over the idea that its a short of some sort... the broken keys on mine are:

    delete: 1qa (brightness down)
    tab: 2wsx`(brightness up)
    down: 9ol.\(also pushes the up key
    quote('): 5tgb-[
    space: 6yhn

    all of them are sporadic.... yhn6work sometimes, don't work other yhn6times, 4 6yhn6the but this is a real pain in the buttt to deal with! i'm going to the apple store in the next couple days to have them tell me whats up

  3. iChan thread starter macrumors 6502a


    Jan 12, 2003
    Dublin, Ireland.
    yeah, hey Josh, mine works fine now... I don't know what did it, but it was definitely a connection problem... as i wrote in an earlier post, i self-installed a new HD...

    it was a pain in the butt like you said about the keys, because for me, i had to disassembly the whole shebang again...

    after putting it back together again, it worked like a charm all over again! shweet!

    good luck...
  4. tibookrenegade macrumors newbie

    Dec 16, 2003
    how exactly do i disconnect the keyboard from the machine? i've popped out my keyboard and tried just pulling it out... but its not working, and i'm afraid to force it before i'm positive thats the way to go.

  5. iChan thread starter macrumors 6502a


    Jan 12, 2003
    Dublin, Ireland.
    I presume, judging by your user name that you a tiBook... I don't know how to do it with that, but you could google it...

    i know on the 12-incher, there is a screw in the Ram conpartment that holds the keyboard in place, basically, two in the front (you have the clip out 4 keys to remove these screws) and the ram conpartment one and the keyboard flips out.

    A word of warning, the keys are not an easy thing to get off first time... you gotta be very very careful and also, simply disconnecting and reconnecting the keyboard was not enough for me, i had the remove the whole cover... don't know why... you could give a shot anyway. goodluck

Share This Page