Kind of a water damages

Discussion in 'iPhone' started by FatPuppy, Apr 26, 2013.

  1. FatPuppy macrumors 68000

    FatPuppy

    Joined:
    Jul 14, 2012
    #1
    I installed one of those orange screen protectors,those that you have to apply a solution,formula and my iPhone was on and now I can only hear the ringtone,messages and other alerts but no sound in games,videos or music,even the keyboard clicks and the lock sound I can't hear.With the headphones,everything works just fine.I tried to clean the dock connector with a toothbrush,I cleaned the 30 mm jack,I used a blow drier with minimum heat from a proper distance,I kept the iPhone turned off for 2 hours,I restored,nothing.And when I unlock the iPhone,I can hear the lock sound once and if I quickly go to spotlight and type,the keyboard clicks work for about 4 seconds.
     
  2. abz1981 macrumors 65816

    Joined:
    Jan 3, 2011
    #2
    Somone how the liquid has affected the handset. Best bet is to take it to apple and get them to look at it.
     
  3. FatPuppy thread starter macrumors 68000

    FatPuppy

    Joined:
    Jul 14, 2012
  4. tardman91 macrumors 6502a

    tardman91

    Joined:
    Oct 21, 2009
    Location:
    Tampa Area, FL
    #4
    How much solution did you use? I've installed tons of "wet" install screen shields over the years, some of which have been VERY wet, and I've never experienced a problem. Just crap luck I guess.
     
  5. ucfgrad93 macrumors P6

    ucfgrad93

    Joined:
    Aug 17, 2007
    Location:
    Colorado
    #5
    Put your iPhone in a bag of rice and seal it up for a couple of days. It might be able to save your iPhone.
     
  6. takeshi74 macrumors 601

    Joined:
    Feb 9, 2011
    #6
    Same here. If you're using enough to cause liquid damage then you're using too much.

    If you suspect liquid damage, immediately power down and allow the device to fully dry for several days. 2 hours is not enough. If you have water damage and you apply power then you've likely caused more damage.
     
  7. FatPuppy thread starter macrumors 68000

    FatPuppy

    Joined:
    Jul 14, 2012
    #7
    Today when I was playing a game,the sounds started for about 3 seconds and than it stopped,I happened 2 times today.
     
  8. tgi macrumors 65816

    tgi

    Joined:
    Aug 29, 2012
    #8
    Have you tried restoring? Maybe it's a iOS glitch.
     
  9. FatPuppy thread starter macrumors 68000

    FatPuppy

    Joined:
    Jul 14, 2012
    #9
    4 times my friend,2 painful hours of restoring.
     
  10. FatPuppy thread starter macrumors 68000

    FatPuppy

    Joined:
    Jul 14, 2012
    #10
    So I kinda fixed the sound problem,everything works perfect,for now.I am on ios 5.0.1 and I installed icleaner pro.Someone said once that my iphone has water damage and it only works with headphone because the hardware thinks that the headphones are connected so I disabled some daemons from icleaner pro like ota daemon,vpn daemon AND accessory daemons(disabling these daemons will render accessories unusable, except for chargers) which means that I can't use headphones anymore.I disabled it and now my sound works perfect and the headphones works perfect as well.WHY?
     

Share This Page