Late 2009 iMac suddenly began "freezing" - mouse responds but nothing works, hard boo

Discussion in 'iMac' started by LemonPepper, Sep 26, 2012.

  1. LemonPepper, Sep 26, 2012
    Last edited: Sep 26, 2012

    LemonPepper macrumors newbie

    Joined:
    Apr 28, 2011
    #1
    As the title says. This problem began last night after this mac has worked for nearly 3 years without problem (excepting my HDD failure last year). I play World of Warcraft a lot, and I noticed the graphics and game sound got funky all of a sudden. When I tried to exit WoW to restart my computer, I couldn't exit any applications normally, and the Cmd-Ctrl-Esc did not bring up the tasks window to force quit anything.

    Using my mouse to select things worked as normal, but upon actual selection, they did nothing and all I get is a beach ball. I have to hold the power button in the back to hard reboot each time.

    It is a similar problem to the one posted here: https://discussions.apple.com/thread/3834722?start=0&tstart=0

    The comp is a 27" 2009 Intel i5 2.66GHz with 12GB ram and a SSD I installed last year myself (again, has been working fine up until last night, when this suddenly began).

    Through my own troubleshooting: I've verified/repaired disk permissions to no avail. I've ruled out WoW, or any application for that matter, as the cause--I duplicated the problem by letting my computer sit, running nothing, while I played on my phone and checked functionality every so often. Same problem occurred around roughly 55min.

    I do not have access to the Apple Hardware Test--pressing D while rebooting has no effect and I am currently stationed in the mid-east for the next month, so I don't have my install disks available.

    In the thread above, OP said his problem ceased when he got his internet cable steady--I connect to a wireless router which has our USB-stick internet in it. While it's not the best internet, I've changed nothing about it since being here and it seems unlikely this would be the cause.

    I was looking at getting a new computer once I returned to my home station, anyway.. but I was planning on keeping this one as well. Does anyone know what might be the issue here as to why this would suddenly begin happening?

    If there's any more information I can provide I will do so. Thank you for reading and any information you might have to help would be greatly appreciated.

    Edit: I have now also tried resetting my PRAM to see if that enabled me to run the AHT; no dice =(
     
  2. LemonPepper thread starter macrumors newbie

    Joined:
    Apr 28, 2011
    #2
    An update to this prolem! This is happeneing every 60 minutes, plus or minutes 1 minute for startup time. 5 times in a row the "freeze" has occurred at the 1 hour mark. I've looked at my system.log while it happened last time but saw nothing, but I really don't know too much about such things, perhaps there is somewhere else I could look that would be helpful?

    As to why this began, that I still cannot say, as it started while I was playing WoW, so I'm unsure what I Could have done to alter something, creating this problem. But a regular freeze like this does point to other things besides a hardware problem, so at least that is good news!
     
  3. Ypresis, Oct 2, 2012
    Last edited: Oct 2, 2012

    Ypresis macrumors newbie

    Joined:
    Oct 2, 2012
    #3
    Hi,

    Just wanna say I just got the same problem, for 2 or 3 days. It happened the first time while I was playing WoW.

    Then it happened yesterday while I was on the finder.

    I'm going to try to change my ram while I'll get home, some threads suggest that on Apple's website.

    Could you try that ?

    I use a 27 iMac i5 3,1 ghz and 9670m.

    Edit : Look likes people in this thread experiencing the same problem https://discussions.apple.com/thread/4168621?start=45&tstart=0
     
  4. LemonPepper thread starter macrumors newbie

    Joined:
    Apr 28, 2011
    #4
    Update again!

    This is remaining as a true unsolved mystery, it seems.

    I haven't posted in a while as things got busy at the end of my deployment but I am back at my home station now, and I have narrowed the problem down even further in my couple days of being back.

    I went through troubleshooting with a 1-time ticket, compensated by Apple for my circumstances a couple days after I posted my previous reply here. I haven't had occasion to contact them for support issues within the last couple years, but kudos to them for giving me an exemption for free over-the-phone troubleshooting for this problem even though my computer is well out of warranty and I have altered it myself (putting in a solid state HD). I went through multiple troubleshooting steps with 2 different reps and also a supervisor. I was most impressed by the fact that I was never asked to repeat a step I'd already done previously--I simply said "here's my setup, here's what I think it might be, here's what I've already done so far" and the process went from there each time--this is how tech support should be.

    Not trying to fanboy, just giving props where due, onto the results/news in hopes that this still-unsolved mystery might gather a solution, or at least the attention from anyone else having the same problem. With tech support I went through every reset imagineable without reinstalling my OS, and then finally did a manual backup of my important files (to do it by time machine took longer than the computer would stay unfrozen) and reinstalled the OS. Nothin doin'.

    Now back home I have access to a boot drive backup I created before I deployed, so I booted off of that with plans to wipe my hard drive completely (again, with a manual backup of important files, drag and drop style) and install anew. For some reason the install disks that came with my computer, my imac would not boot off of at all. They are 10.4.7, could be due to my newer hard drive which I only put in 1.5 years ago, whereas the comp is otherwise nearing 3 years old. I don't have the knowledge to confirm if that's the case or why, but either way, whenever I tried to boot from the disks, either by pressing C or holding the option key and selecting the disk, my comp simply froze--waited up to 61 minutes with no boot, and no change in screen.

    Someone had suggested in another similar thread that this problem resolved when they got a more stable internet connection: I've now tried 7 configurations of internet/no internet--direct plug-in to my USB-stick in the desert, airport connection to wireless router in desert, airport disabled in both locations, direct plug-in to active cable modem here, airport connection to wireless router here, wireless connection to laptop hosting wireless server while connected to ethernet here. Nothing has changed on that mark, so I think it's safe to say this can be ruled out as a dissimilar issue.

    The last step I've now tried is operating off of what I began this post with--functioning off of the backup, bootable partition I created on an external drive prior to my deployment, and thus prior to this issue occurring. I was at first encouraged as I passed the 1 hour mark and was still able to open and close a few programs (the few I tested) without any CPU beachball and subsequent restart. However, upon trying to empty the trash, the process never completed. I was able to open the force quit apps menu with Cmd-Opt-Esc (something not possible before) but after clicking Releanch for Finder, nothing ever came back up and I had to resort to a hard restart.

    So, this is the longest rant possible, to give as much information as possible, and I apologize sincerely for any redundancies. I'm still looking for help on these and tomorrow I will see if I can swap RAM with a local mac repair guy just to try something new.

    At this point it looks like the $2k computer I have enjoyed so much for nearly 3 years has essentially zero resale value, since I can't even gaurantee which part may be broken and causing this issue. I am currently in the process of migrating all the functionality this computer once provided onto a used powerbook I bought from a friend in the desert, and searching for a new primary gaming computer, probably a custom-built PC laptop from a friend very knowledgeable in such things.

    Again, sorry for the rant, but I've said all I can in the hope that anyone with the same problem might find all I've gone through here and, if recreating all my steps fails as my process has, at least take solace that they're not the only one.
     
  5. MatthewAMEL macrumors 6502

    MatthewAMEL

    Joined:
    Oct 23, 2007
    Location:
    Orlando, FL
    #5
    My guess is your HDD is going bad.

    'Spinning beach ball', or momentary, seemingly random freezes (during or after boot) is a common symptom of a failing drive.

    You have a 2009. Have you checked your serial number at the Apple support site? You are most likely eligible for the free HDD replacement.

    2009 i7's are still fetching ~$750 on eBay. Pretty good for a 3-year old computer.
     
  6. motrek macrumors 68020

    Joined:
    Sep 14, 2012
    #6
    Possibly an obvious question but do you mean it happens after ~1 hour of idle time? If so, that points to a power management problem. Maybe the computer is not able to turn off the screen or enter sleep mode correctly. Try turning this stuff off in the System Preferences UI?
     
  7. LemonPepper thread starter macrumors newbie

    Joined:
    Apr 28, 2011
    #7
    I replaced the HHD with a SSD a year and a half ago. I'm getting some ram to switch out as well as a new SSD today so I will be able to check which is the problem, if either. Could be that I just have ban luck with hard drives.

    Negative, it was always 1 hour precisely after pushing the power button. I say power button because doing a pre-emptive "Restart" did not prevent the problem. I started setting a timer for 57 minutes whenever I turned it on and would do a Shut Down after it went off so that I wasn't constantly losing changes I'd made to freezes.
     
  8. bitmand macrumors newbie

    Joined:
    Sep 20, 2013
    #8
    Any follow up to this thread?

    I'm having a similar problem, but mine is not bound to an 1 hour limit. It just happens randomly once every 1-2 days. But otherwise very similar.

    Also iMac 2009 with after installed SSD, same freeze - mouse works, but everything else is frozen. And annoying as hell :)

    Wonder if you solved the problem with yours?
     
  9. djrod macrumors 65816

    djrod

    Joined:
    Sep 16, 2008
    Location:
    Madrid - Spain
    #9
    Same problem here, 2009 27" iMac with custom installed SSD in the Superdrive bay.

    It seems the thing we all share is the custom SDD, that might be the issue?
     
  10. Sofad macrumors member

    Sofad

    Joined:
    Jan 24, 2006
    #10
    imac 2009, m500 ssd

    Hi, i join the club

    iMac 2009, replaced the superdrive with an ssd. After a few hours the system freezes. Mouse is still moving. No errors in console log.

    Maybe the superdrive caddy is the problem?

    Have you tried to run the system on the spinning hard drive?
     
  11. McFlossy, May 18, 2014
    Last edited: May 18, 2014

    McFlossy macrumors newbie

    Joined:
    Oct 22, 2009
    Location:
    Oakland, CA
    #11
    Maybe Startup Apps?

    Just responding in case anyone else comes across this issue. Had the same exact problem (minus the 60 minute timing). My late 2009 iMac began to freeze about 2 days ago. I too play a lot of WoW. I've also replaced my recalled Seagate 1TB HD with a Seagate 2TB Hybrid drive, although not in the superdrive slot. I actually replaced the actual boot drive and upgraded the RAM from 4 to 8GB.

    Hard reboot brings Mavericks up as normal. No issues. Programs would run, but would just freeze within the first couple minutes. I typically run a pretty heavy load (Photoshop, 5-10 tabs in Chrome, 3-4 finder windows open, 3-4 preview windows open...graphic design) with no issues.

    I reviewed this thread and the thread on the Apple support site this one refers to. Checked my home network, reset everything. Same problem. Ran the Apple Hardware Test. No issues. I have a Time Machine back up, but I just replaced my hard drive about 3-4 months ago, so I have a relatively new installation and didn't think that was the problem. I was just about to go into safe mode and see if there were some problems with startup programs and had an idea--upon reboot, before it freezes I had just enough time to kill some startup programs I thought my be problematic:

    Boxee
    Growl

    Why these programs? Well the Boxee Mac client is something that used to support viewing Mac videos on your iPad. It's no longer supported and you can no longer download it, but it was still working. Non-supported programs are always suspect since they'll never be updated to support newer OS iterations. I killed that and set it to no longer start on boot.

    Growl, while still supported, has updated to a pay model. It is great and I've used it for years on my Mac, but with Lion/Mountain Lion/Mavericks, Apple has gone to their own notifications. I still get Growl notifications, but they're often duplicated. Could there possibly be some kind of conflict on startup? Did the recent update cause contention in apps vying for the same notification DB? Who knows, but an application trying to access something another app is using could definitely cause a lock/freeze of some sort.

    It could have been either of those programs and while most won't have Boxee, many will have Growl. The solution that worked for me was disabling both from starting on boot and I'm back to being a happy camper. It's clear that there are a series of issues involved with this, but since this thread helped me troubleshoot, I just wanted to publish the solution that worked for my machine.

    Good Luck! :rolleyes:

    McFlossy
     
  12. lordreye macrumors newbie

    Joined:
    Aug 21, 2009
    #12
    Any News?

    I have a small business and we have two of the 2009 27" iMacs. One of them is experiencing this problem. I really hate to replace an otherwise working machine, but every day or few days this workstation stops responding, other than mouse movement.
     
  13. infantrytrophy, Nov 5, 2014
    Last edited: Nov 6, 2014

    infantrytrophy macrumors regular

    Joined:
    Oct 27, 2013
    #13
    I have a 27" late 2009 iMac, that has experienced the freeze problem described about for many months. Mouse cursor will move, but no response to mouse clicks or keyboard input. Same story with bluetooth mouse (Magic Mouse) or USB mouse/keyboard. Apple Store Genius bar did 3-day hardware test, no hardware problems detected.

    This **may** have resolved recently, so I will describe what happened to see it this helps anyone else:

    I just "replaced" the 2009 iMac with a new 27" 5K Retina iMac. In the process of setting up the new iMac and migrating data/apps/settings from the older Mac, I called Apple Care and asked about the problem with the older Mac. The AppleCare rep, after consulting with a more senior tech, started a new "case" and had me go through the usual verify, then repair disk permissions procedures. Then she had me launch the Finder to identify and remove certain items in the Macintosh HD/Library/LaunchAgents and .../LaunchDaemons folders. The following were removed: com.google.keystone.daemon.plist, com.google.keystone.agent.plist, com.barnesandnoble.nookconnect.plist. The first two files are apparently a Google app updater file; the last one deals with a Barnes and Noble Nook connect capability. I left in place an "epson" plist file that related to my printer.

    Finally, I re-booted into Safe Mode and operated the older iMac for over 24 hours. It ran V-E-R-Y slowly in safe mode, but did not have the "mouse freeze" problem. I then re-booted normally and have been running this older Mac for 3 days without a problem.

    I'm not sure which part of the above procedure produced the apparent "cure". It may have been the removal of the plist files mentioned, since the verify/repair disk permissions had been tried before without success. Those of you who are experiencing the problem might try the above, then please post here with your results.

    Added note: the disk drive in the affected iMac is a standard "spinning" drive, not a SSD.
     
  14. qunit macrumors newbie

    Joined:
    Oct 22, 2014
    #14
    I too seem to have this problem on an old 2007 C2D iMac. It started few weeks ago on Mavericks. After a certain time (somewhere between 1 and 3 hours) I get the beachball and cannot do anything anymore. It doesn't matter if I'm doing heavy stuff or just browsing or nothing at all.

    The problem remains after a fresh install of Mavericks and later Yosemite.

    In common: have replaced the original harddrive with an SSD.


    The last 6 months ago I also started getting some bottom backlight problems (flickering and lower intensity) but the machine worked flawlessly.

    Since it is an older machine I decided to go for the new Retina iMac, but if it turns out that it is a common problem I would prefer if we could find out the cause and/or a remedy.
     
  15. Tucom macrumors 65816

    Tucom

    Joined:
    Jul 29, 2006
    #15
    Experiencing the same exact problem on a Late 2009 27 iMac. Replaced HDD with SSD, which requires shorting the temperature sensor. I doubt that's the cause.


    Running a fresh install of Yosemite from a USB drive.
     
  16. macjosch macrumors newbie

    Joined:
    Dec 16, 2014
    #16
    Graphics Card freeze lock-up stall, NVDA NVIDIA GT120, iMac

    It's been a pain since Snow Leopard.

    I would not call it a freeze or stall. There is no spinning beach ball. It happens always without warning, but there is always a last mouse movement involved when it happens.

    My symptoms were a complete lock up, no clock seconds, no mouse cursor movement. If I played music, it would sound like a skipping CD.

    The Console did not show any suspicious entries until a couple of days ago. And this time, the Console did record something!

    kernel: NVDA(OpenGL): Channel timeout!
    kernel: NVDA(OpenGL): Channel exception! exception type = 0x8 = DMA Engine Error (FIFO Error 8)

    I also had some strange partial screen flicker and finally the mentioned lock-up.

    I have been searching the web for years, replaced RAM, removed USB hub, ran Hardware Test, installed smc Fan Control later Macs Fan Control, but I still had lock-ups occurring once a day to once a week.

    Finally I came across a hint as follows (don't credit me for that):

    Go to directory /System/Library/Extensions/

    look for AppleGraphicsPowerManagement.kext
    and change its name to
    AppleGraphicsPowerManagement.kext.disabled

    You will need admin privileges to do that.

    Now reboot into Safe Mode and then boot normally afterwards. That will clear the boot cache.

    Always keep a back-up of your system. Your mileage may vary (In other words, it is always your fault).

    Cheers,

    Joachim
     
  17. charles6980 macrumors newbie

    charles6980

    Joined:
    Dec 27, 2014
    #17
    I was hit by the same issue, I think, just some days ago. The solution for me was to update my Crucial m4 SSD's firmware.

    If you own one of those, you might try to do that as well. You can check with "System Information" under "Hardware" -> "SATA/SATA Express". The "Model" entry should read something like "M4-CTxxxM4SSD2" with "xxx" being the capacity in gigabytes.
    If the "Version" entry of your Crucial M4 SSD is not 0x070 (hex number, latest firmware revision), you are most likely affected, see http://www.tomshardware.com/news/Crucial-m4-Firmware-BSOD,14544.html

    Steps to diagnose:
    1. Open a Terminal window, type caffeinate -d (to prevent sleep mode).
    2. Open another Terminal window, type (or copy: be sure to get the backticks right, these are not normal single quotes!) while `true` ; do uptime ; sleep 1 ; done (i.e, print uptime stats, sleep a second, print again, to get the time until failure).
    3. Open another terminal window, type while `true` ; do ls -laR ~ > /dev/null ; sleep 1 ; done (do some file system activity to get diagnostic useful diagnostic output in the moment of failure).
    This needs to run until one hour of uptime is reached. Now, if you see the message "device not configured" in one of the latter two Terminal windows, with the uptime something between one hour and one hour and 5 min, it's the firmware issue (with above 95% certainty). Getting this very error message might need some number of tries, though (3 for me).

    Steps to fix:
    Easy solution, if you have an optical drive: download the crucial firmware update, burn on CD, upgrade. For a bootable USB drive:
    1. Download the firmware upgrade from crucial's site: http://www.crucial.com/support/firmware.aspx
    2. Follow the guide http://forums.macrumors.com/showthread.php?p=20399673 to make a bootable USB drive.
    3. BEFORE rebooting, mount the Crucial ISO image (by doubleclicking). The volume name in Finder should be displayed as "CDROM".
    4. Eject and re-insert the USB drive. The SYSLINUX and rEFIt volumes will be mounted.
    5. On the SYSLINUX partition, replace the file BTDSK.IMG with the file BOOT/ISOLINUX/BOOT2880.IMG from the Crucial firmware image.
    6. Boot from your USB drive, follow the instructions on the screen.

    ...that's how it worked for me.
     
  18. coin3d macrumors newbie

    Joined:
    Jan 7, 2015
    #18
    I don't think that the problem is related to shorting of the HDD sensor, since I replaced my SuperDrive with the SSD - the problem occurred as well. I thought that the "SSD Bay" is the reason, that's why I replaced my regular HDD with the SSD: However, the problem still persists. Every now and then the GUI freezes, only the mouse works - but: all tasks are still running (i verified that by sshing onto my mac during a freeze)

    Another thing: My graphics card broke two years ago. I disassembled my iMac, put the graphics card into the oven and re-assembled the iMac - everything worked again. But since these kind of fixes often don't last forever, I'm not totally sure if my freeze problem is related to my broken-and-baked graphics card.

    One last thing: I'm pretty sure Apple bought GPUs of lower quality - if you keep looking for defect, late 2009 iMacs on eBay you will find plenty of iMacs with defect graphic cards :(
     
  19. dawoife macrumors newbie

    Joined:
    Feb 20, 2015
    #19
    solved with Trim Enabler on 21" 2009 iMAC

    Hi folks,

    I've had exactly the same issues on my 21 inch 2009 iMAC after SSD upgrade (in optical drive bay).
    I was not aware that there is a must-install tool when upgrading to a ssd afterwards, that is "trim enabler" which controls free / deleted space on the SSD.

    After having installed it the freezing problem disappeared ;-)

    However now after Yosemite there are some caveats after changed Apple SW Architecture which means that you need to de-activate trim enabler prior to any OSX upgrade. Everything is well described on the trim enabler home page (http://www.cindori.org/trim-enabler-and-yosemite/).

    It still works like a charm ;-)
    Hope this will help you as well...

    dawoife
     

Share This Page