Late 2011 13" MacBook Pro won't turn on, is making a humming noise

Discussion in 'MacBook Pro' started by Jessica Lares, Jun 15, 2014.

  1. Jessica Lares macrumors G3

    Jessica Lares

    Joined:
    Oct 31, 2009
    Location:
    Near Dallas, Texas, USA
    #1
    OKAY, I know the thing is a goner. I tried two outlets, and two chargers with no luck. The thing is making a small hum noise that probably would have to be boosted to hear very clearly, and there's no sign of any power from it otherwise.

    At 3AM I went to go plug in my iPod to charge and thought nothing of it.

    Now it's 6:30...

    What the heck happened?! I did mention my GPU/screen issues in another thread, but otherwise it wasn't apparent that the thing was going to completely die on me.
     
  2. Jessica Lares thread starter macrumors G3

    Jessica Lares

    Joined:
    Oct 31, 2009
    Location:
    Near Dallas, Texas, USA
    #2
    Well this is weird! After the 100th time of desperately hoping that the charger would come on, this morning I hooked it up to my old 2006 MacBook Pro and confirmed that there was nothing wrong with it. So I try once more with the 2011... AND IT WORKED.

    It's kinda sluggish, but I'm hoping with a PRAM reset and maybe a reinstall of Mavericks that it'll be good to go again.
     
  3. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #3
    Could be the MagSafe board going as that is indicated by the humming noise and that would explain the intermittent starting issue.
     

Share This Page