Late 2012 iMac, Erased SSD+(new)SSD, Can't boot, fix or access via Target Disc Mode

Discussion in 'macOS Mojave (10.14)' started by Billzabub, May 24, 2019.

  1. Billzabub macrumors newbie

    May 24, 2019
    I am having a lot of problems with my Late 2012 27" iMac not booting (and not letting me install, run diagnostics tests etc)...

    Ok... I'll try and keep this concise:

    Late 2012 3.4Ghz 8MB iMac worked great for years - started to get some random restarts last year - was running High Sierra

    Tried an update to Mojave - failed - and iMac no-longer would boot / kept power re-cycling

    Took it in for repair at good authorized Apple repair center. They managed to get all data off the Fusion drive (128GB original SSD/NVME + 1TB HDD). They tried reinstalling OS (I think they put original Snow Leopard on there). But kept getting re-boots.

    Told me it was likely a Logic Board fault which would cost $800 or I could leave with them for recycling...

    I decided I wanted to try and save the machine - I had read that the PSU boards on late 2012 iMacs often caused this sort of problem - so I brought the iMac home - learned how to open it up (iFixit) - bought a refurbished different PSU board for $100 and fitted it.

    Did a quick test - and it booted ! hurrah.

    At this point I thought I would give the machine a bit of boost so bought a 1TB SSD (Samsung EVO 860) and swapped out the HDD for the SSD. I expected this to kill the fusion drive setup - and it did - but I was ready to install Mojave from external USB disk I had made

    This didn't seem to work - but when I tried Recovery mode from Internet, It remade fusion drive, installed High Sierra - and booted! So was super happy, re-sealed screen to machine and had a working iMac again.

    So then... I tried installing Mojave again (10.14.4)... seemed ok to begin with then crash... then didn't boot and wouldn't even get to disk utilities or Terminal with my Mojave USB install disk

    So I thought maybe the fusion disk setup was the culprit - and therefore if I could reset that - maybe unfuse the drives and install OS X to NVME and use the 1TB for applications and user data...

    I bought a firewire cable (and a new Mac book Air....) and used Target Disc Mode - I could see drives - I ran first aid on them - no errors. I tried lots of different boot options - in the end I erased them both to try and get rid of fusion setup (pic is before erase).

    Everything I did hasn't helped getting past a stuck progress bar on the Apple Logo.

    I can't do internet recovery, USB recovering, Paragon Hard Disk Manager USB Key, Apple diagnostics (via internet) - I get same error about Can't load EFI...

    So then I thought if its nothing to do with my internal drives (which should be blank) - maybe its my memory... so I tried removing one 4GB bank - same results. tried other... same results...

    The only thing I can get into is Single User Mode - but not sure what to do there to help....

    Before I start believing it is a logic board problem I really want to rule out some kind of SW/Firmware issue - or test HW somehow and check it works - but remember - I have NO OS installed at the moment

    ... update ...

    things are getting worse - now I can't even see the drives in Target Disk Mode :( - the host is showing Firewire symbol - but no drives appearing on my Mac Book Air (which I just upgraded to 10.14.5 - hope that hasn't caused that).
    If I use Single User Mode (with as USB 10.14.4 key in) I see the drives *are* there (with ls /dev/disk*) - but I don't seem to be able to run fsck on them (only the USB 'root')

    What do I need to do in Single User Mode to be able to a) check other drives, b) see them in Target Disk Mode please?

    On another thread there is lots of talk of the latest Mojave EFI Firmware 224.0.0 being buggy - e.g. stopping Cmd-D diagnostics from working:

    Error: 0x8000000000000003, Cannot Load 'EFI/Drivers/TestSupport.efi'
    Status: 0x00000003

    I get this too so I can't easily check what is working and what isn't

    p.s. I changed my RAM tonight - NO change.

  2. Fishrrman macrumors P6


    Feb 20, 2009
    You have another, working Mac, right? (MacBook?)

    Do this:
    You'll need a USB flash drive 32gb or larger, or an external hard drive.

    Do this on the OTHER Mac (not the problem iMac).

    Install a clean copy of the OS of your choice onto the USB flashdrive or external drive. Set it up with a basic administrative user account.

    Now, take this drive to the problem iMac.
    Can you boot the iMac from it?

    WHY you're doing this:
    You need a way to boot the iMac from an EXTERNAL drive that has a copy of the OS on it that is "bootable to the finder".
    This will demonstrate whether the problems with the iMac are drive-related, or are coming from somewhere other than the internal drive(s).

    If the iMac boots and runs ok from the flashdrive, then it's the internal drives that need work...
  3. Billzabub thread starter macrumors newbie

    May 24, 2019
    --- Post Merged, May 25, 2019 ---
    So yes, I have Mac Book Air with 10.14.5 running on it.
    I understand in principle what you are suggesting - but all guides I see on the net talk about creating a USB bootable Mac OS X *installer* disk, not a bootable to finder USB disk.
    But I have tried the Mojave installer usb and also a recovery/paragon disk manager USB which are basically cut down boot versions and both of these stall while loading...
    So.. newbie question to everyone, if I option boot and select an external drive am I running any internal efi firmware that is on any internal storage/nv memory?
    Or is it that the standard external boot is trying to access the internal drives and getting confused and hanging?
    My point is that without opening up the damn machine (and I'd like to avoid cutting through all the adhesive it too me ages to get right) I can't isolate what is happening from what could still be lurking on some partition of those drives.
    Any pointers to creating a minimal external boot USB would still make sense.

    BTW one thing someone suggested was create a high Sierra install USB but I can't even download the install from Mojave 10.14.5 (with direct link) it won't let me.
    Here's photo of where it hangs when I try and boot with verbose mode on.
  4. Fishrrman macrumors P6


    Feb 20, 2009
    "I understand in principle what you are suggesting - but all guides I see on the net talk about creating a USB bootable Mac OS X *installer* disk, not a bootable to finder USB disk."

    I've shown you "the pathway forward".
    Whether you choose to walk it is... up to you.

    Try doing what I've recommended that you do.
    Then get back to us.
  5. Billzabub, May 25, 2019
    Last edited: May 25, 2019

    Billzabub thread starter macrumors newbie

    May 24, 2019
    20190525_135935.jpg Ok... I borrowed a neighbor's Mac Book Air which was running High Sierra 10.13.6. I installed an external bootable version of High Sierra on external USB/T5 SSD. It worked on his Mac. Remembered to change his Start Up drive to Internal before I finished with machine (that would have been awkward otherwise).
    Now when I do Option boot I get option of "Mac OS X 10.13.6" or "Recovery 10.13.6".
    They both get stuck on the apple loading progress.
    Haven't tried verbose or Single User Mode yet.

    The only thing I can think of which isn't a 'logic board failure' is boot rom mismatch now... (if it was HW then why was High Sierras running before I tried the Mojave update?)

    How can I find out what Boot ROM EFI I have now (I suspect 224 still...) - and then downgrade?
    There is the last Apple EFI standalone ROM for this model - Late 2012 27" Intel 3.4 on this page -
    is there any way to update Boot firmware from Single User Mode?

    ... Update

    Single User Mode works and obviously this is better position now that it is a full Mac OS X disk (10.13.6) environment (thanks for this).

    I don't know enough about diagnosing things from this point.

    You can see the other drives are enumerated in the screen shot
    --- Post Merged, May 25, 2019 ---
    Here's some more info on the HW and SW build versions.

  6. Billzabub thread starter macrumors newbie

    May 24, 2019
    Ok... here is the Panic detail from the last time I tried to boot from that 10.13.6 Ext Mac OS X -

    Anonymous UUID: FA4168BD-C794-AA5B-5B97-30CF9280A87A

    Sat May 25 15:30:28 2019

    *** Panic Report ***
    panic(cpu 2 caller 0xffffff7fadd70692): "bool IOAccelDisplayMachine2::display_mode_did_change(uint32_t): vendor driver returns false"@/BuildRoot/Library/Caches/
    Backtrace (CPU 2), Frame : Return Address
    0xffffff821a32b770 : 0xffffff802bc6c1c6
    0xffffff821a32b7c0 : 0xffffff802bd95274
    0xffffff821a32b800 : 0xffffff802bd87544
    0xffffff821a32b870 : 0xffffff802bc1e1e0
    0xffffff821a32b890 : 0xffffff802bc6bc3c
    0xffffff821a32b9c0 : 0xffffff802bc6b9fc
    0xffffff821a32ba20 : 0xffffff7fadd70692
    0xffffff821a32ba50 : 0xffffff7fadd9d4a1
    0xffffff821a32ba90 : 0xffffff7fadcf4a76
    0xffffff821a32bb40 : 0xffffff7fadce19bc
    0xffffff821a32bb80 : 0xffffff7fadcebf09
    0xffffff821a32bba0 : 0xffffff7fadcef91f
    0xffffff821a32bc20 : 0xffffff7fadce717a
    0xffffff821a32bc70 : 0xffffff7faec2e8ab
    0xffffff821a32bcc0 : 0xffffff802c26cc2f
    0xffffff821a32bd10 : 0xffffff802c2c95a7
    0xffffff821a32bd70 : 0xffffff802bd426a2
    0xffffff821a32bdc0 : 0xffffff802bc716e0
    0xffffff821a32be10 : 0xffffff802bc4ea3d
    0xffffff821a32be60 : 0xffffff802bc6154b
    0xffffff821a32bef0 : 0xffffff802bd7171d
    0xffffff821a32bfa0 : 0xffffff802bc1e9e6
    Kernel Extensions in backtrace:[0E507098-E375-39B7-9AE2-AFF2C7A5D961]@0xffffff7fadcd8000->0xffffff7fadd20fff

    BSD process name corresponding to current thread: WindowServer
    Boot args: -s

    Mac OS version:

    Kernel version:
    Darwin Kernel Version 17.7.0: Thu Jun 21 22:53:14 PDT 2018; root:xnu-4570.71.2~1/RELEASE_X86_64
    Kernel UUID: 1AE5ACFD-3B6F-3D74-AD52-31F1430DBC6F
    Kernel slide: 0x000000002ba00000
    Kernel text base: 0xffffff802bc00000
    __HIB text base: 0xffffff802bb00000
    System model name: iMac13,2 (Mac-FC02E91DDD3FA6A4)

    System uptime in nanoseconds: 5633105056349
    last loaded kext at 5628918843458: 1.70 (addr 0xffffff7faf28f000, size 28672)
    last unloaded kext at 61412868287: 900.4.1 (addr 0xffffff7face11000, size 12288)
    loaded kexts: 1.70 3.0 3.20.13 3.20.13 1 1.0.1 6.0.7f10 7.0.0 1.0.0 110.23.37 2.7.0d0 3.6.5 281.52 131 1 10.3.2 10.3.6 3.20.13 281.52 281.52 1 800.21.30 1.0.0 3.1.1 170.12.6 10.3.1 6.0.7f10 3.1 211 1 1240.19.1a3 4.0.0 4.1.0 10.3.6 10.3.2 1.5.5 1.0.0d1 1.0.0 1.0 40 407.50.6 748.51.0 1.7.6 329.50.2 2.0 6.1 1.8 2.1 6.1 1.7 220.50.1 183 3 8 220.50.1 1.0 3.20.13 11 680.2 680.15 1.0 10.3.2 10.3.2 281.52 526 3.20.13 1.0.0 1.1.0 519.20 281.52 281.52 206.5 1.2.0 1.1.0 1.0.14d1 1200.12.2 1.0.1b8 1.0.4 1.0.0 1.0.0 6.0.0d8 4.1.4 378.26 211.15 3.20.13 1.0.18d1 519.20 6.0.7f10 6.0.7f10 6.0.7f10 6.0.7f10 1.2 5.0.0 1.2 1.2 1 5.5.5 5.5.5 5.5.5 2.1.3 301.40.2 4.7.2 6.7.8 288 1.2 1.2 1.2 1.2 1.0 900.4.1 1.2 2.1 2.1 1.1 2.0.0 300.0 1.0.0d1 28.30 1.0 2 439.70.3 1.0.5 140.70.2 404.30.2 404.30.2 1.0 1 1.2 1.0 1.0 1.0.1 1 480.60.1 2.1 680.15 3.4 31 6.1 3.1.9 2.9 1.4 1 1 1.0


  7. Billzabub thread starter macrumors newbie

    May 24, 2019
    --- Post Merged, May 31, 2019 ---
    Update from today - It's either firmware incompatibility or my logic board (GPU?) really is a goner...
  8. Fishrrman macrumors P6


    Feb 20, 2009

    Have you ever tried to do what I suggested in reply 2 above?

    That is, install a copy of the OS onto an EXTERNAL drive, and then try to boot from that?
  9. Billzabub thread starter macrumors newbie

    May 24, 2019
    Yes Fisherrman, as I said further up I created both a 10.13.6 and 10.14.5 full external OS image to boot from as you suggested (thanks) . They both stall as UI Process starts up with issues in Windowserver process - as shown in the kernel panic logs.

    My only hope is High Sierra started up before so maybe the logic board/GPU is actually ok it's only something the firmware has screwed up.
  10. Fishrrman macrumors P6


    Feb 20, 2009
    "Yes Fisherrman, as I said further up I created both a 10.13.6 and 10.14.5 full external OS image"

    "OS Image"???
    Something's not right here, or there's a language problem.

    If you created a bootable external drive, it would not be "an image".
    It would just be "a drive" that you could boot from.

    That's how I'm seeing it.
  11. Billzabub thread starter macrumors newbie

    May 24, 2019
    Yes drive. Sorry. Wrong terminology.

Share This Page

10 May 24, 2019