League of Legends on rMBP 15" with 750m - fps drop

Discussion in 'MacBook Pro' started by pscl, Nov 15, 2013.

  1. pscl, Nov 15, 2013
    Last edited: Nov 15, 2013

    pscl macrumors 6502

    Joined:
    Jun 3, 2013
    #1
    hey

    i was wondering if any of you might play league of legends on the rMBP 15" with 750m.

    If i play in 2048x... i get constantly 60 frames (cabbed at 60fps, not cabbed ill get 130-140fps) with vsync on. but randomly the frames drop to about 20, or 30 for 10-20 seconds.

    no matter what i do (set the res down, low details) there is always some fps drop. so im pretty sure its not a gfx-power problem.

    any of you lol players experiencing something like this?

    on my imac i can play native, with very high details without a problem (512MB vRam). wtf?!

    edit:
    Formus say, that it might be a heat issue? smc reset didnt work for me.

    greets
     
  2. yangchewren macrumors regular

    Joined:
    Dec 1, 2012
    #2
    Hmm, perhaps your should confirm this through installing aida 64 http://www.aida64.com/

    and reporting back what your power consumption is.

    It may be that LoL is particularly CPU intensive during certain portions or well threaded and is hence boosting your processor speed and taking energy away from the GPU.

    However, a more likely explanation is a driver issue.
     
  3. MaclandValhalla macrumors member

    MaclandValhalla

    Joined:
    Oct 3, 2013
    #3
    I'm assuming you're getting better performance from the Iris Pro. This isn't entirely uncommon, and it's why the top Apple speculators agree that this might be the last generation of MacBook Pros with dedicated GPUs.

    Some applications perform better with the Iris Pro; others perform better with the dedicated GPU. It's a toss-up.

    Your ideal solution (not for everyone, obviously) is to disable the dedicated GPU while gaming.

    EDIT: Here's an article that will help you with that: http://www.macrumors.com/2012/07/10/gfxcardstatus-allows-easy-control-of-macbook-pro-graphics-cards/
     
  4. Freyqq macrumors 68040

    Joined:
    Dec 13, 2004
    #4
    Turn off vsync. It usually causes problems.
     
  5. isephmusic macrumors 6502

    Joined:
    Oct 31, 2012
    #5
    yea turn off v sync, make sure its not network lag, and run the game borderless window mode
     
  6. aiyaaabatt macrumors 6502

    Joined:
    Aug 25, 2013
    #6
    Could also be that your dGPU is overheating and down clocking itself to stabilize temps.

    You should monitor your temps while this FPS drop happens and report back. Are your fans running on maximum (~6000 RPM) while you are playing?
     
  7. Sadisterr macrumors member

    Joined:
    Sep 1, 2013
    #7
    I have the same problem as OP, clean installation of Mavericks, got MBP 15 mid 2012, does not matter what graphics settings in LoL I use, or what graphics card I use, the problem occurs anyway. Sadly, it is not the only game under OS X. Similar problem with Driver: San Francisco and so on.
     
  8. pscl, Nov 15, 2013
    Last edited: Nov 15, 2013

    pscl thread starter macrumors 6502

    Joined:
    Jun 3, 2013
    #8
    thanks for your statements.

    i dont know i tryed everything. almost.

    now, that i got such a powerful machine, im running win 8 in parallels, perfectly fine. all smooth, nice fps...

    but its sad that the native client is so bad... and im still wondering why my 2011 imac performs so well
     
  9. shansoft macrumors 6502

    Joined:
    Apr 24, 2011
    #9
    This is not true at all. In gaming, there is no way Iris Pro can go on top of a dedicated GPU.(Synthetic benchmark maybe...) Both of the GPU are in a complete different league and far apart. If somehow Iris Pro is doing better, then something is differently off.

    To OP: Download Lobbo's fan control and turn on the fan all the way up, then use Throttlestop to prevent CPU throttling. I have similar issues and was due to rMBP's horrible cooling design.
     
  10. pscl, Nov 15, 2013
    Last edited: Nov 15, 2013

    pscl thread starter macrumors 6502

    Joined:
    Jun 3, 2013
    #10
    if this is the problem, then why do i have way better fps on bootcamp/parallels ??

    i guess this is a league of legends programming problem. maybe the 750m or the rmbp isnt yet supported.
     
  11. Epicsack macrumors newbie

    Joined:
    Aug 6, 2010
    #11
    I have last years rMBP and it ran lol perfectly until mavericks
     
  12. CitrusPisser macrumors member

    Joined:
    Apr 20, 2013
    #12
    LOL is not the only game effected, methinks the NVIDIA drivers need some tweaking/an update for Mavericks.
     
  13. howareyoukk macrumors regular

    Joined:
    Apr 1, 2013
    #13

    turn off the shadows and your fps will be stable. Speaking from my personal experience :)
     
  14. pscl thread starter macrumors 6502

    Joined:
    Jun 3, 2013
    #14
    Shadows always off.

    I think it is a Client Problem!
    Parallels win8 runns like a Dream!

    Maybe the Mavericks update will adress possible driver issues...
     
  15. aRandomDude macrumors newbie

    Joined:
    Mar 5, 2016
    #15
    If you're using a mouse software try disabling it (my razer synapse on osx was getting me drops in almost every game).


    As far as my experience goes, LoL on mac is not optimized for lower resolutions.
    I'm used to playing on 1680 x 1050 or 1440 x 1900 for bigger health bars and targets, but when I tried it on my rmbp OSX Marvericks (also gt750m) I was getting tremendous fps drops (from 200+ to 30- every few seconds),
    then I switched to 2048 x 1280 and was getting very stable fps (I capped it at 120 and it wasn't going lower than that).

    I recommend turning V-sync off and Anti-Aliasing off (they're not well optimized).


    Also note that spectating games should run A LOT SMOOTHER on your Iris pro.
    The reason it gives you better performance is probably because your cpu does not have to process the keyboard and mouse inputs which will result in GFx outputs. When spectating a game it is only processing data received from a server.

    So if you're opening your client to spectate games make sure to run gfxCardStatus and set it to "Integrated Only" before opening ur client.


    Also if Riot ever decides to switch from OpenGL to Metal then you should definitely update your OSX to El Captain.
    https://en.wikipedia.org/wiki/Metal_(API)
     
  16. Hewthetitan macrumors newbie

    Joined:
    Mar 14, 2016
  17. kotty macrumors member

    Joined:
    Jul 9, 2010
    #17
    Here is the same thing.....
    I have a Macbook 15 with Geforce 650m, and I also have this fps drops..... it's very annoying. Tried to lower my settings, go to fullscreen, or windowed, but it's still the same.
    Shadows off
    Aa: off
    Medium graphics...
     

Share This Page