Limited Upgrade of 3GS from 4.1 to 4.2.1

Discussion in 'iPhone Tips, Help and Troubleshooting' started by OLight, Jul 15, 2012.

  1. OLight macrumors newbie

    Joined:
    Jul 15, 2012
    #1
    Hey folks...

    I'm trying to upgrade a 3GS on 4.1 (BB 05.14.02) to 4.2.1 *and no further*. Basically, I'm trying to use as low of a version of iOS to keep the device as lean as possible; I figure once I get newer and newer firmware, the hardware will be less and less able to support it without lag. I need 4.2+ only to run the app for my Nest thermostat.

    I've downloaded the IPSW (8C148), backed the device up, hit shift-Update and pointed to the IPSW I've downloaded, but always get the same message: "The iPhone "(name)" could not be updated. An unknown error occurred (3194)."

    I have the feeling I'm missing something simple. Can someone point it out to me, or tell me how else I'm doing it wrong? TIA!
     
  2. Shamil macrumors newbie

    Joined:
    Jul 17, 2012
    #2
    you can only upgrade iphone 3GS to IOS 5.1.1.
     

Share This Page