Lion putting hard drives to sleep (unwanted) and waking up by itself

Discussion in 'Mac OS X Lion (10.7)' started by Goldfinger, Jul 24, 2011.

  1. Goldfinger macrumors 6502

    Joined:
    Jan 7, 2006
    Location:
    Belgium
    #1
    My Mac Pro is putting my hard drives to sleep even with the "put hard drives to sleep" option unchecked in the energy settings. Is anybody else seeing this ?
    It drives me nuts, clicking on a hard drive takes ages to let it spin up.

    Another annoying issue is that the machine is waking up by itself every 2 hours it goes back to sleep 1 minute later (it wakes up without turning on the monitor).

    This is what console has to say during the time the system is awake:
    Code:
    24/07/11 10:56:46,000 kernel: Wake reason: RTC (Alarm)
    24/07/11 10:56:46,000 kernel: RTC: maintenance alarm 2011/7/24 08:56:45, sleep 2011/7/24 06:56:46
    24/07/11 10:56:46,000 kernel: Previous Sleep Cause: 5
    24/07/11 10:56:46,703 configd: network configuration changed.
    24/07/11 10:56:46,718 applepushserviced: <APSCourier: 0x10a61bfb0>: Stream error occurred for <APSTCPStream: 0x7f8363526e20>: The operation couldn’t be completed. Socket is not connected
    24/07/11 10:56:46,719 applepushserviced: <APSCourier: 0x10a61bfb0>: Stream error occurred for <APSTCPStream: 0x7f8365d01670>: The operation couldn’t be completed. (kCFErrorDomainCFNetwork error 2.)
    24/07/11 10:56:48,000 kernel: Ethernet [Intel82574L]: Link up on en0, 100-Megabit, Full-duplex, No flow-control, Debug [796d,6c08,01e1,0200,41e1,4000]
    24/07/11 10:56:48,710 configd: network configuration changed.
    24/07/11 10:56:52,000 kernel: 00000000  00000000  Intel82574L::timeoutHandler - has to reset the chipset once since there is still no link for the workaround
    24/07/11 10:56:56,000 kernel: Graphics suppressed 10108 ms
    24/07/11 10:56:56,118 configd: network configuration changed.
    24/07/11 10:56:57,746 configd: network configuration changed.
    24/07/11 10:57:01,702 UserEventAgent: ServermgrdRegistration cannot load config data
    24/07/11 10:57:01,702 UserEventAgent: ServermgrdRegistration oldConfig is nil during net changed notification

    (this is on a Lion clean install system)
     
  2. Tutorer macrumors member

    Joined:
    Jun 9, 2011
    #2
    I have the 2 hour wake up issue with a Mac Mini. I clean installed Lion on it, but the disk has 10.5.8 Server on another partition of the drive. I mention this because of this message:
    UserEventAgent: ServermgrdRegistration cannot load config data

    I don't have a solution for this wakeup problem, yet. Have not really put any effort into it, either, because it's just a test installation.

    Do you have a server installation on one of your partitions?

    Ciao
     
  3. UCF Sam macrumors regular

    Joined:
    Mar 4, 2010
    #3
    This is happening to me also. Did you ever find a fix?
     
  4. Celeron macrumors 6502a

    Joined:
    Mar 11, 2004
    #4
    Do you have Wake On Lan enabled? If so, it will wake up every 2 hours to advertise its services to the network. I have a Mac Mini that does this so the Bonjour Sleep Proxy in my Airport Extreme knows its still around. This is normal, expected behavior.

    Disable Wake on Lan if you aren't using it.
     
  5. Simon Templar macrumors member

    Simon Templar

    Joined:
    May 6, 2010
    Location:
    Infinite Rider on The Big Dogma
    #5
    I've had the Intermittent Wake-up ever since Tiger. So far it has not happened as yet with Lion....but I only switched over this week, so it hasn't had time to manifest itself as yet.

    Nobody so far has been able to explain why this happens nor how to rid myself of it.



    ....sT
     
  6. Tutorer macrumors member

    Joined:
    Jun 9, 2011
    #6
    It actually is like you say. It did not behave that way in Leopard, but that's the way it is with Lion.
    When you disable wake on lan and then reenable it you get a notification regarding this behavior. Clicking the question mark in that dialog gives some more information about mobile computers.

    I'd rather have it behave the way it did in Leopard, because I want to use wake on lan, but don't want the intermittent wake ups every 2 hours. Maybe this can be accomplished via different means?

    Ciao
     

Share This Page