Lion-Safari laggy when entering Japanese

Discussion in 'Mac Apps and Mac App Store' started by ChristianJapan, Jul 29, 2011.

  1. ChristianJapan macrumors 601

    ChristianJapan

    Joined:
    May 10, 2010
    Location:
    日本
    #1
    My wife got successfully converted to Mac with SL on a MBP. She was happy and said: nice, the computerbis soo fast when I enter Japanese characters.

    Now under Lion there is a significant delay in many cases where the system stops for a part of a second. I also tried and it really disturbs a bit when entering fast some text.

    Does anyone have an idea to speed that up. Funny enough in mail application it looks fast enough at all times.

    So I assume it's more related to Safari then to Lion.
     
  2. blipmusic macrumors regular

    Joined:
    Feb 4, 2011
    #2
    The slight "freeze" only occurs the first time kotoeri (if you are using Apple's input) loaded into ram in my case. After that, switching is instant. No problem with slow character input either. I have an aging MBP (2,2 GHz C2D and only 2GB ram), by the way.

    That goes for every app I'm in, mostly a text editor (apart from TextMate, but that's for other reasons) but Safari is no different in my experience.

    Perhaps just wait a few seconds for it to load the first time you switch to Japanese input?
     
  3. kutsushita macrumors regular

    kutsushita

    Joined:
    May 9, 2010
    Location:
    Houston
    #3
    hmm thanks for bringing this up. my girl is usually set on things staying how they are and doesn't care about the newest flashy things. i've been trying to get her to switch to lion as i already have but now i may have to test the input to make sure she can type in japanese easily so i don't get yelled at :p
     
  4. ChristianJapan thread starter macrumors 601

    ChristianJapan

    Joined:
    May 10, 2010
    Location:
    日本
    #4
    Japanese input is on from start onwards. It also happen that from time to time a little input field shows up left-down of the window where the input gets first selected and copied into the text field after pressing ENTER.

    Didn't saw that for years. I also tried to hange the encoding setting for pages with Default, UTF8 or ShiftJIS, but no permanent help.

    Will try alternative browser.
     
  5. blipmusic, Jul 31, 2011
    Last edited: Jul 31, 2011

    blipmusic macrumors regular

    Joined:
    Feb 4, 2011
    #5
    Oh, you mean it's the default input language after boot-up? Mine isn't so kotoeri is loaded only after I press my shortcut for Japanese input, sorry for the confusion.

    Still, could be that some component is loaded the first time you actually write, like the dictionary for kana -> kanji conversion (just a guess). Of course one would expect it to be a tad more smooth on a modern computer. Perhaps check the activity manager before and after you first write in Japanese after boot-up?

    The little pop-up input field usually comes up when no input area, such as the address bar or a text editor, is explicitly selected. In my case it's also sometimes the case when an app isn't native or in the case of a text field in a third party plug-in. Sometimes an accidental scroll on the magic mouse puts focus away form the input area just as I'm about to write etc.

    [EDIT: Seems to be ok in both Safari and Chrome in my case, by the way (though Safari is beach balling alot regardless and currently feels generally buggy in Lion. Character encoding in a browser shouldn't have any impact on input lag AFAIK - that said, let's hope Japan one day finally agree on *one* encoding standard]
     

Share This Page