Little spill - any way to disable one key on MacBook keyboard?

Discussion in 'MacBook' started by SanibelMan, Sep 7, 2008.

  1. SanibelMan macrumors member

    Joined:
    Jul 1, 2004
    #1
    So there was a little spill the other day. I mopped up quickly, but now the right arrow key isn't working. It seems to twitch by itself occasionally - while trying to watch DVDs, for example, I'll suddenly skip forward in chapters to the end. Is there any way to disable the key through Terminal or something? If not, is there a way to tell the computer to ignore keyboard input if an external keyboard is attached, similar to how you can tell it to ignore trackpad input when a mouse is attached?
     
  2. suimpreza16 macrumors newbie

    Joined:
    Aug 5, 2007
    #2
    I actually had this same exact problem today! you might also experience a few other keys going out.... the first key that went for me was the h.. then the a.. etc. I took it to a genius I am friends with and he disabled the internal keyboard for me. There is a ribbon underneath the battery that he disconnected. It has blue at the end. Now I'm using an external keyboard until the new internal one comes in. good luck!
     
  3. SanibelMan thread starter macrumors member

    Joined:
    Jul 1, 2004
    #3
    Hmm, thanks. I hope it doesn't get any worse. How much did a new keyboard cost, and what's involved in replacing it?
     
  4. Chandler Adaway macrumors 6502a

    Chandler Adaway

    Joined:
    Jun 29, 2008
    Location:
    Beaumont, TX
    #4
    You can go to www.iFixit.com I believe, and it will have detailed instructions on how to replace it. From what i hear, it's pretty easy to do.

    Good luck, and stay away from drinking around your Mac! It's never worth it.
     
  5. Skeletal-dæmon macrumors 6502

    Joined:
    Apr 27, 2008
    #5
    Although that said... a small water spillage, as long as its just water with nothing else at all in it, can usually be dried out.

    ... he says, glancing sadly at his old Apple Pro Keyboard which got lemonade on it and the sugar killed it stone dead.
     
  6. wilgallo macrumors newbie

    wilgallo

    Joined:
    Sep 6, 2009
    #6
    888888888888888888888888

    im leaving all the unintentional 8's in this reply, to illustrate just how ann8888888oying a problem this is

    hey skeletal, why not throw that out?

    also8888888888888888888 i 888888f88in8d8 88888888888888888888888 - sorry...its ridiculous that the only solution to this problem (other than replacing the internal keyboard) is to physically disconnect the cable....very lame
     
  7. jbuk macrumors regular

    Joined:
    Jun 8, 2009
    #7
    I expect the reason you can't disable the internal keyboard in software is to do with the key-combinations required at startup for certain modes (CD boot, Target disk etc.)
     
  8. Nate3000 macrumors newbie

    Joined:
    Sep 13, 2009
    #8
    I tried putting my MacBook Pro into Target Disk Mode with a USB keyboard and it worked, so I doubt that's the case.
    I am having the same problem with my internal keyboard (spilled water into it, and now some of the keys go crazy). Thoughts?
     

Share This Page