Lost permission to see the content of 2 internal hd's after installing

Discussion in 'OS X Yosemite (10.10)' started by Sjakie, Dec 4, 2014.

  1. Sjakie macrumors newbie

    Joined:
    Dec 4, 2014
    #1
    After installing Yosemite on my Mac Pro 2.1 (using the SFOTT script) I somehow lost permission to see 2 internal hd's. One of them is my Time Machine backup disk...

    In the Get Info window it says under Sharing & Permissions that I have custom access, and when I try to change the Privilege I get "The operation can’t be completed because you don’t have the necessary permission"
    I tried to verify the disk in Disk Utility, but it was okay. When I try to repair it anyway it returns the message "Unable to unmount volume for repair"
    I also repaired the disk permissions of my startup drives.

    When I boot into Snow Leopard from another internal drive I still have the same problem.

    I know next to nothing about the terminal but I did try the 'sudo chown -Rv' command. It goes through the whole list of files that are on the hd but then returns with the 'Operation not permitted' message.
    There must be a way in the terminal to unlock the disks. Does anyone know the right command maybe? That would be great!

    For the rest Yosemite runs fine so far :)
     
  2. Sjakie thread starter macrumors newbie

    Joined:
    Dec 4, 2014
    #2
    fixed

    Finally found a solution, thanks instageek!

    instageek
    Sep 7, 2009 1:00 AM
    Re: "don't have permission to see its contents"
    in response to instageek
    I found a solution over on Macrumors forums, though it's not for the faint of heart. The solution starts at post #36, about halfway down the page:

    http://forums.macrumors.com/showthread.php?t=417647&highlight=ACL&page=2

    As I suspected, this is a Terminal / Unix / Command-line procedure, and anyone uncomfortable with it should probably just take their Mac to the Genius Bar at their local Apple store. That said, below is the procedure that worked for me (I'll make it easier for those who don't want to read the whole thread on macrumors.com).

    Also, the first procedure is ONLY FOR HARD DRIVES/VOLUMES WITH ONE-WORD NAMES. If you have two or more words in the name(s), the procedure is slightly different, and I've listed that below the first procedure.

    *1. Open an application in your Utilities folder called Terminal.*

    This is the Unix part of Mac OS X that does not have a GUI (graphic user interface). Think of it like working in DOS (or BASIC), if you're as old as I am. It's also a bit like a word processing program, only much more powerful.

    You type a command (_EXACTLY, character for character, space for space, as it is shown in the example_) and then hit ENTER or RETURN to execute the command. After the first ENTER/RETURN, you will probably have to enter your account password (or an administrator password if you're not logged in as such).

    You won't see any characters appear as you type your password, (the cursor remains in the same place) but continue typing it and then hit RETURN/ENTER.

    2. In Terminal, CUT AND PASTE the following lines +one at a time+ (obviously replace "Volumename" with the name of your volume). Make SURE you include spaces where there are spaces. And those are ZEROS after "chflags" and "chown", not Oh's.

    Hit RETURN/ENTER after the "Volumename", and watch your HD's icon on your desktop after each command. In my case, the little padlock disappeared first, then my custom icon was restored, and then it was just blink blink every time after. But it works!!! REMEMBER, THIS FIRST PROCEDURE IS ONLY FOR VOLUMES WITH SINGLE-WORD NAMES:

    *sudo chflags 0 /Volumes/Volumename* <HIT RETURN/ENTER HERE> (don't type this part in Terminal.
    *sudo chown 0:80 /Volumes/Volumename* <HIT RETURN/ENTER HERE>
    *sudo chmod 775 /Volumes/Volumename* <HIT RETURN/ENTER HERE>
    *sudo chmod -N /Volumes/Volumename* <HIT RETURN/ENTER HERE>

    BUT if your volume's name includes one or more spaces like this: "My HD Backup", then you must write the command like this (Notice the spaces :

    sudo chflags 0 /Volumes/firstname\ secondname\ thirdname\ fourthname\ fifth etc.
    sudo chown 0:80 /Volumes/firstname\ secondname\ thirdname\ fourthname\ fifth etc.
    sudo chmod 775 /Volumes/firstname\ secondname\ thirdname\ fourthname\ fifth etc.
    sudo chmod -N /Volumes/firstname\ secondname\ thirdname\ fourthname\ fifth etc.

    or like in my example:

    Quote:
    sudo chflags 0 /Volumes/My\ HD\ Backup
    sudo chown 0:80 /Volumes/My\ HD\ Backup
    sudo chmod 775 /Volumes/My\ HD\ Backup
    sudo chmod -N /Volumes/My\ HD\ Backup

    That should do it! Hope it works for everyone with this problem. Thanks to "IEatApples" on MacRumors for the solution!

    For anyone who cares, here's what another MacRumors user (angelwatt) said these commands actually do:

    1. chflags 0 removes all flags from the file(s)
    2. chown 0:80 ensures root:admin (owner:group) permissions so the system can access the files
    3. chmod 775 adjusts file permissions so you and your group have read/write/execute permissions
    4. chmod -N removes the ACL (Access Control Lists) from the named file(s)

    Cheers!

    *disclaimer: I take no responsibility for any mucking up this does to your machine due to mis-types by you or me. But pull up your bootstraps, be brave, this works!
     

Share This Page