Low-quality video coming out of iDVD?

Discussion in 'Mac Apps and Mac App Store' started by Scorch07, May 5, 2009.

  1. Scorch07 macrumors 6502

    Joined:
    Dec 16, 2007
    #1
    Ok so here's what I'm doing: I've got a movie I'm exporting from FCE, just in the standard "Export to QuickTime Movie" option. The file looks fine (other than the fact that, when I watch it in QT, the aspect ratio is wrong). When I put it into iDVD and let it burn, the video just looks... weird. I'm not sure how to describe it, exactly, but it's just weird. I can't figure out what's wrong. Is it possible it's something in iDVDs conversion to MPEG-2? I'm confused.
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    iDVD is a DVD editor, not a viewer. If you want to view the DVD, then use DVD Player.
     
  3. spice weasel macrumors 65816

    Joined:
    Jul 25, 2003
    #3
    I think he understands that. He is using iDVD to burn his project to DVD, and saying that the resultant video quality looks bad.

    To the OP: what do you mean by "weird"? Is it bad quality, is it an aspect ratio problem, macroblocking, pixelation? Has the video you are trying to master to DVD already been transcoded (working from an avi file or something like that)? Is it that iDVD is just over-compressing the file? Have you tried exporting from FCE to a different format, like h.264? If that results in better quality, then I would say iDVD is over-compressing the MPEG2.

    I've never really bothered with iDVD, preferring instead to just encode to h.264, so I can't really offer much beyond this. Sorry.
     
  4. Scorch07 thread starter macrumors 6502

    Joined:
    Dec 16, 2007
    #4
    Yeah I think it's just over-compressing it. The "burned" area on the DVD is literally about .75 cm wide. I know it should be wider than that for nearly 30 minutes of video... I did try it in H.264, but then when I threw that into iDVD, the aspect ratio was all messed up (and it was fine when I just played the H.264 file in QT). Well, I say the ratio was messed up, it just like... double-letterboxed it, if that makes since. Like it put black all the way around the video, making it not fill the entire space. I thought that was pretty ironic considering the other one played with a weird ratio in QT but was right on the DVD.
     
  5. Scorch07 thread starter macrumors 6502

    Joined:
    Dec 16, 2007
    #5
    Hmmm, I just found the encoding preferences in "Project Info" and ironically, Best Performance resulted in the disc space devoted to the video doubled, and tyhe little quality bar thing went solid green, so I guess I'll try that. I'm guessing that is able to be under "better performance" since it actually requires less encoding.
     

Share This Page