Mac App Store asking to "Accept" iMove and iPhoto, over and over and over again....

matt2053

macrumors 6502a
Original poster
Jul 8, 2012
549
101
Every time I open the Mac App Store since upgrading to Mavericks, I am asked to "Accept" iMovie and iPhoto, even though I've had them since I bought my first Mac two years ago, and even though I click "Accept" every time I see it. Any idea how to make it stop?
 

Attachments

guitarman777

macrumors regular
Sep 15, 2005
210
33
Orlando, FL
Every time I open the Mac App Store since upgrading to Mavericks, I am asked to "Accept" iMovie and iPhoto, even though I've had them since I bought my first Mac two years ago, and even though I click "Accept" every time I see it. Any idea how to make it stop?
Very odd. I ended up downloading & installing the iMovie 10.0 update twice and thought that was weird, but your situation is quite bizarre. Hmm...
 

Regal Sauce

macrumors newbie
Oct 24, 2013
3
0
Same problem

My son is having the exact same problem on his macbook. Exactly the same as your screenshot.

Would welcome any suggestions.
 

badman89

macrumors regular
Dec 24, 2011
212
0
Every time I open the Mac App Store since upgrading to Mavericks, I am asked to "Accept" iMovie and iPhoto, even though I've had them since I bought my first Mac two years ago, and even though I click "Accept" every time I see it. Any idea how to make it stop?
I'm also facing the exact same problem as you (screenshot), and I have no idea what to do about it.
 

bernhard

macrumors member
Oct 25, 2004
58
7
Vienna, Austria
I had that problem right after buyin the rMBP, which comes bundled with iLife.
After a few days the annoying messages stopped and everything returned to normal.
 

matt2053

macrumors 6502a
Original poster
Jul 8, 2012
549
101
It finally seems to have stopped for me. If you are having this issue, I guess just wait a few days.
 

brentg33

macrumors 6502a
Mar 5, 2007
550
0
It finally seems to have stopped for me. If you are having this issue, I guess just wait a few days.
Did you have to stop hitting the accept button for a few days for it to go away?
I mean, every time i open the MAS, i usually try to "Accept"
....maybe i should just leave it alone?


I have the same issues since doing a clean install. But mine has yet to go away. Actually, my account is currently in troubleshooting mode with Apple to try and fix?
 

matt2053

macrumors 6502a
Original poster
Jul 8, 2012
549
101
Did you have to stop hitting the accept button for a few days for it to go away?
I mean, every time i open the MAS, i usually try to "Accept"
....maybe i should just leave it alone?


I have the same issues since doing a clean install. But mine has yet to go away. Actually, my account is currently in troubleshooting mode with Apple to try and fix?
Haha well, it came back one day last week. Now, it's gone again....

I'm at a loss. I believe I finally did just leave it alone.
 

brentg33

macrumors 6502a
Mar 5, 2007
550
0
ok thanks.....i'll leave it alone and wait till Apple gets back to me about their findings. I do have them installed. my worry was not getting future iphoto/imovie updates....
 

mikehalloran

macrumors 68000
Oct 14, 2018
1,646
415
The Sillie Con Valley
Ancient thread, I know, but my wife's iMac has had this annoyance for years. iMovie only since iPhoto is no longer a thing.

Has anyone ever found the solution? No one I've talked to at Apple seems to have heard of it (does anyone there know how to Google?).

I'm on her machine right now. Have logged in and Accepted again — as I do 2–3x per year.

iMovie fires up and is at v. 10.1.11 — Wiki says the latest version is 10.1.10 so I know it's been updating and there's no real problem.

Still, it's things like this that annoy me.
[doublepost=1556994570][/doublepost]Hmmm... I may have found the solution. I deleted iMovie and tried to Install from the Purchased list in the App Store — no go because it won't Accept. Ok, I expected that.

So, I went back 10 minutes in Time Machine and restored iMovie — took about a minute (love APFS Snapshots!). Closed the App Store and reopened. The Accept box is gone. ??? Ok, that's good...

So, pushing my luck, I trashed iMovie again, closed and reopened the App Store again. The Accept button is gone and when I clicked on Install, it downloaded and installed like it was supposed to.

I'm declaring victory. Hope this helps someone else.