Mac Book Pro fails to connect to home wifi

Discussion in 'MacBook Pro' started by SuppleContours, Apr 18, 2012.

  1. SuppleContours macrumors newbie

    Joined:
    Apr 18, 2012
    #1
    Hello,

    I have a macbook pro running Leopard, OS X 10.5.8 and I am attempting to connect to my home wifi and sadly failing. It tries to connect only to say the connection times out. We use a netgear router however in my household we have a couple other macbooks, which connect fine, both android phones and iphones which connect fine, and a pc laptop which also connects to our wifi fine. However mine remains stubborn.

    We have called the cable company and everything looks fine on their end, we have also rebooted the modem and router, as well as my macbook of course, but those efforts were fruitless. I have forgotten the network and tried again, created a new airport, created whole new networks, sadly all those efforts were fruitless as well.

    I took my macbook pro into the apple store, they ran a diagnostic and said it was nothing to do with my hardware. The genius employee went into my hard drive, into the library, to the system configurations and cleared it. However upon my return home, still not able to connect to the wifi. I connected fine at the apple store and also connected fine at starbucks not but an hour ago. However I am typing this message on my android phone to see if any of you have any nuggets of wisdom for me before I return to the apple store. Any and all help you can give me would be greatly appreciated! Thank you for any advice you may be able to provide me!
     
  2. BookieBear macrumors newbie

    Joined:
    Feb 24, 2011
    #2
    That's weird.. I'm having the same problem except I'm on Lion. I can connect to my 5ghz channel but not my 2.5ghz channel. I could before, but now all of a sudden I can't...
     
  3. bruinsrme macrumors 603

    bruinsrme

    Joined:
    Oct 26, 2008
    #3
    I had a problem this morning.

    I had a DNS entry in the table different than my home network.
    Once deleted I was able to connect.
     

Share This Page