Mac Book Pro Wifi Dies, but doesn't show disconnect, Requires Restart

Discussion in 'OS X Mavericks (10.9)' started by dieseltwitch, Feb 26, 2014.

  1. dieseltwitch macrumors regular

    Joined:
    Jan 24, 2008
    #1
    I've been having a problem ever sense I install 10.9. (now at 10.9.1)

    My WiFi will work for 20-30 min. then the connection drops, I lose connection to my server, downloads stop... but it never shows that the wifi isn't connected in the menu bar at the top. If I open up network settings its hit or miss as to if it shows up. If I turn the wifi and off and try to turn it back on nothing happens.

    I end up having to restart to get the wifi to work again. I've done 2 full formats and installs of 10.9 I've also uninstalled and reinstalled the wifi in the network setting. I've also done a P-Ram Reset... to no avail.

    Its doesn't matter what router Im connected to. Been in 15+ different offices/homes and it happens no matter what.

    Here is all my model info http://support.apple.com/kb/SP4

    Basicly a late 2008 MBP 17"
     
  2. graley macrumors regular

    Joined:
    May 25, 2010
    Location:
    Australia
    #2
    Wifi not working in OS 10.9

    Go to system prefs...network...location is probably automatic. Change it to something else, like home. It workd for me
     
  3. anp27 macrumors regular

    Joined:
    Jan 17, 2011
    Location:
    Brooklyn, NY
    #3
    I had the same problems in 10.9.1. I upgraded to 10.9.2 and the problems are gone. It seems like the beach ball problem is gone too!
     

Share This Page