Mac can't see airport express or servers after about an hour on wifi

Discussion in 'Mac OS X Server, Xserve, and Networking' started by blueeye, Aug 20, 2011.

  1. blueeye macrumors member

    blueeye

    Joined:
    Oct 27, 2007
    #1
    Hi all,

    I've been having a few annoying problems with my network.

    My network has:
    • wired: mac mini, printer, small server
    • wifi: macbook pro, airport express, iphones

    I retired my old Netgear DG834Gv2 in favour of a new Billion 7300n based on it having good reviews.

    I often rely on being able to access my local server by, for example, using
    Code:
    ssh servername.local
    
    I also use my airport express constantly to stream music.

    ---

    Now, having upgraded both OSX (to Lion) and my router (to 7300n) I am having the following problems:
    • On freshly connecting to the network, my macbook pro uses airport express/server perfectly.
    • After a while (I don't know how long exactly, maybe an hour) iTunes pauses and won't play because it says it cannot find the airport express.
    • Airport utility can see the APE but cannot connect to it.
    • I can no longer access my server using it's hostname, but only its IP address.

    NB:
    My iPhone can always access the APE (but this could be because it regularly disconnects and reconnects to a network (ie if it is idle, it disconnects).
    As far as I can tell, the wired Mac Mini doesn't have this problem, but I will test more thoroughly and update.

    All devices on the network are assigned fixed IPs by the router, the attached screenshot shows my wifi settings.
     

    Attached Files:

  2. blueeye, Aug 20, 2011
    Last edited by a moderator: Aug 21, 2011

    blueeye thread starter macrumors member

    blueeye

    Joined:
    Oct 27, 2007
    #2
    Ok, disabling that WMMM thing seems to have fixed one part of the problem: I can now (seemingly) connect to my airport express consistently.

    It does not, however, solve the problem of being unable to connect to my server/other computers by ssh or through the finder (netatalk on the server with avahi and the other mac mini using bonjour).

    Interestingly, the wired computers can always communicate with each other easily. I can't get a reliable connection to or from my macbook (wireless).

    I wonder if this has something to do with the "RIP" settings under the ethernet page?

    There are lots of different options and I'm not entirely sure what they're for (see attached screenshot).

    Thanks.

    I take it back, airport express problem is not fixed by turning off the WMMM thing :( Back to square one.
     

    Attached Files:

  3. blueeye thread starter macrumors member

    blueeye

    Joined:
    Oct 27, 2007
    #3
    In addition (following the trend) my macbook pro can't see the printer on the network, even though the wired mac mini can..

    Can anyone help?
     
  4. wartooth macrumors newbie

    Joined:
    Nov 14, 2007
    Location:
    Melbourne
    #4
    Possible Work Around

    Blueeye,
    I have had exactly the same experience with my Billion 7300n and my macs when using bonjour over wireless. It is very frustrating and I have not been able to find a solution. I did think of a possible work around just last week which seems to be working so far.

    I simply turned the Billion into a '802.11g' only router. Go to Advanced ->Configuration ->Lan ->Wireless. Select '802.11g' from the Mode pull down menu.

    Of course this means the 'N' wireless router is now just a plain old 'G' type router which is not ideal.

    Let me know how you go or if you came up with any other solution (or you already tried this suggestion).

    FYI, I'm on Snow Leopard and using the latest firmware on the router (1.08a). I have had this router for over two years and I am reasonably sure it worked fine for the first few months or more (on an older firmware). I eventually used a second router to take care of wireless duties over the last 18 months until I gave it another look last week (when the modem was having connection issues).
     
  5. blueeye thread starter macrumors member

    blueeye

    Joined:
    Oct 27, 2007
    #5
    Hi wartooth,

    I had a long exchange with Billion themselves (which they kept stalling on, for the record - it was very frustrating). I have found that the following settings have dramatically improved my experience:

    • Wireless Channel: 6
    • Encryption: WPA2/AES
    • Group Key Renewal: 0
    • "g" only

    Now I do get occasional cut-out on my Airport Express but otherwise everything seems to be working. It's been a long and frustrating road, so I hope these settings help anyone looking for it.
     

Share This Page