Mac Mini 2010 - Can someone please explain to me how to get 5.1 surround via HDMI?

Discussion in 'Mac mini' started by Baron Aloha, Jul 6, 2010.

  1. Baron Aloha macrumors newbie

    Aug 19, 2009
    I have been looking everywhere for days trying to figure this out...

    I am a total OSX noob but I was able to search and find that I should go under Applications > Utilities > Audio Midi Setup to configure the output. I set it up for 5.1 surround and tested each of the speakers and they work.

    However, if I try to play a DVD movie either directly off the disc or an MKV that I've encoded I always only get sound from my front speakers. I've tried a bunch of different DVDs and MKV files and a bunch of different programs including the built in DVD player, Front Row, Plex, and VLC Player.

    I should mention that I am running the HDMI from my Mac Mini directly to my receiver. And like I said, when I tested the speakers under Audio Midi Setup they were working properly. I've even checked the options for the various programs and made adjustments when possible. Still no luck....

    Can anyone with the new mini and a similar setup that has had success give me some tips or point me in the right direction? Thanks.

    Also my apologies if this has been answered before, I did a few searches but I couldn't find anything that answered this particular question.
  2. macrumors newbie

    Jun 17, 2010
    Barcelona, Catalonia
    Hi, I've got a similar setup. But I'm connecting directly to my TV, which in turn outputs sound to my receiver.

    I've not had any problems getting 5.1 to work. I'm using PLEX as a media center app. It seems to detect the capabilities of my receiver automatically.

    Have you checked that the video player software you're using has got surround activated (e.g. in VLC > Preferences > Sound, you can force it to check for surround sound).

    Also, just to be sure: the way you configure audio output is always via the Preferences panel. Make sure everything is connected and your receiver is switched on, then open Preferences > Sound > Output and ensure you've selected your 5.1 receiver there. You didn't mention this step before, so I apologise if you've already done that!

    Also, be aware that some users have reported slightly confusing behaviour if the switch their Mini on *before* their receiver, as the Mini can't find the default output so switches to internal speaker instead. Aim to switch your receiver on first, I guess.
  3. Baron Aloha thread starter macrumors newbie

    Aug 19, 2009
    Thanks for the reply!

    I definitely think you are on to something when you say to make sure that the receiver is selected. That is definitely what I would like to do but I have been unable to do so. Part of the problem is that when I first hooked up my Mini I connected it via HDMI directly to my television. When I did that, I went under Preferences > Sound > Output and it detected my television (it came up as Samsung).

    However, since then I've connected the Mini via HDMI to my receiver and when I go to Preferences > Sound > Output it still shows "Samsung" but my receiver is Yamaha. The receiver isn't even an option. Its almost as if the Mini sees the HDMI connection but assumes that it is still connected to the it isn't actually re-evaluating what its connected to.

    I tried a few things to get it to refresh (even called Apple but the guy was no help) but it is still coming up as Samsung.

    I'm tempted to re-install the OS. There has got to be a way to force it to re-check.
  4. OldMike macrumors 6502


    Mar 3, 2009
    Dallas, TX
    Just a wild guess, but have you tried setting it back to the Mini's internal speaker, rebooting and then seeing what your option is for digital out? Maybe it can't re-detect since digital out is still selected?

    I'm sure someone knows how to reset this - it must be recorded in a file that can be deleted somewhere...
  5. indg macrumors 6502

    Feb 7, 2007
    i don't know if this will work, but try this:
    1. power off mini.
    2. disconnect hdmi from receiver to tv.
    3. connect hdmi from mini to receiver.
    4. turn on receiver.
    5. set receiver to 5.1 (DD) mode if possible.
    6. power on mini.
    7. see if sound output preferenes shows the receiver as a device now.
  6. SmilesLots macrumors regular


    Apr 30, 2010
    SW Virginia
    You may have to delete one or more plists to get it back to where it will look for whatever is connected to hdmi.
  7. a2applegirl macrumors regular


    Jun 16, 2010
    I have a bose surround sound system and the only way I was able to get it to work was to input the mini to the tv via hdmi then output from the tv to the receiver via toslink optical, then output from the receiver to the subwoofer and all the speakers.

    Also, be aware that if you re-encode in handbrake, you will not get 5.1 surround unless you either check a special option for a second surround audio track, or you compress video only.

    Otherwise you will only get stereo sound.
  8. Baron Aloha thread starter macrumors newbie

    Aug 19, 2009
    UPDATE: I was able to fix the problem.

    SOLUTION: I hooked the Mini up to the receiver via HDMI, booted from the OS X disc and did a complete reformat of the HDD and reinstall of the OS. After the OS was reinstalled I went to System Preferences > Sound > Output and my receiver was listed. I selected it and rebooted. Upon reboot the lights for the front speakers, sub woofer, and l/r rear speakers lit up on my receiver (previously the sub woofer and l/r rear speakers didn't light up).

    So my advice to anyone out there planning to connect the Mini via HDMI directly to a receiver is to do so from the get go the first time you turn it on because apparently if you switch to a receiver afterwards OS X might have a hard time detecting the receiver...even if you delete all of your preferences and whatnot beforehand.
  9. Irishman macrumors 68030

    Nov 2, 2006
    This is a great tip for those of us who care about surround audio and are thinking about using the Mini as a HTPC.

    By the way, have you tried running Boxee as a front-end for streaming content on your Mini? If so, how'd it go?
  10. rollocla macrumors newbie

    Sep 12, 2008
    So, why am I always the bloke out here who has this problem, but none of the causes listed here?

    • The Mac Mini shows my Panasonic receiver down to the model number...
    • I've used the Audio MIDI setup
    • I encoded everything in Handbrake WITH the AC3 passthrough switched on on a second channel.

    I've resorted to taking the image from the HDMI socket through the DVI connector and the audio from the Optical output and both into a box that mashes them together into an HDMI output and then on to the receiver.. this gives me 5.1 surround where-as a direct HDMI output gave me front left and right, subwoofer and (I think) centre channels only.

    I tried setting up the audio many different ways in the Audio MIDI set-up but no joy, so thank the Universe I had the mixer box from the previous Mac Mini being used as a media centre.

    Hopefully someone could still post here and tell me how to fix this issue.
  11. ahankinson macrumors member

    Feb 1, 2010
  12. rollocla macrumors newbie

    Sep 12, 2008
  13. rollocla macrumors newbie

    Sep 12, 2008
    For anyone else reading this thread.. please note: you also have to set the output to 2 channel 24bit... silly of Apple to not make it say 5.1 as it'll confuse a LOT of new users I think.

Share This Page