Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Mac Mini 2011 black screen on startup

alexeiphone

macrumors newbie
Original poster
Mar 22, 2011
3
0
Hi,

I have a 2011 Mac Mini with dedicated AMD graphics and have a problem.
This machine was previously starting up with a black screen, but after trying many different suggestions from the internet, I somehow got it working again and it had been running for some months (and it was possible to successfully reboot it).

However, it has now gone back to its old behaviour and I can’t get anything to display on the screen.
The power light comes on and the Mac chimes, but there is no picture.
I’ve tried via DisplayPort and HDMI, but no luck.

I run FING on my phone, but it’s not detecting any new devices joining the network, so I’m not sure if the Mac is actually starting!?
The display is definitely not the problem as it works with other devices and I’ve also tried connecting the Mac to my TV.

I’ve tried all the various options for troubleshooting at startup (disconnecting the power cable and waiting a number of seconds, key presses for booting into diagnostics, safe mode, resetting NVRAM/PRAM, startup manager), but nothing results in a boot screen or any other output to the monitor.

At one point, it did briefly look as if something was happening, as the TV detected a resolution change, but then it started behaving like before and at no point was the Mac bootup screen displayed.

I know this is an old machine, but I’d love to get it back up and running, so can anyone help?
It’s very power efficient, but can also provide speed when needed; I use it as a home server.
Also, a new base level Mac Mini costs £799 in the UK ($1025), which I really am not looking to spend.

I’ve read about suggestions for heating up the logic board, but that seems to be a temporary solution.

Thanks.
 

zterm

macrumors newbie
Mar 1, 2018
8
2
Hi, I wonder if you finally found a solution.

My Mac Mini from late 2012 works fine, but I always wondered why during startup it shows a black background screen with a white logo and a process bar.

Yesterday I decided to investigate and having no luck did a fresh install of Mojave on a new SSD in hopes that the black screen would go away with the newer operating system. After booting, everything seems to work correctly and with the new SSD I have noticed a change for the better, but it bothers me not to know why the boot is different from the rest of my Macs.

Any help will be appreciated.

zterm
 
Comment

mdgm

macrumors 6502a
Nov 2, 2010
954
47
The AMD Graphics in the 2011 Mini has been known to fail. 2011 Minis without that GPU are likely to last longer. If the AMD GPU is the problem it'd be time to get a newer machine. I suspect that could well be the problem.

You could try booting with just one RAM stick installed to see if the RAM is the problem (that's an easy thing to check).
 
Comment

Nedstah

macrumors member
Jun 27, 2018
92
78
North Carolina
I resurrected a 2011 with AMD graphics by removing the old thermal paste and repasting with Arctic Silver. There are two locations on the front and the back of the motherboard. As with yours, black screen but howling fans as well. It's running fine now with a fresh install of High Sierrra.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.