Mac OS X ignores fast double clicks — a bug?

Discussion in 'macOS' started by Dae, Sep 2, 2010.

  1. Dae macrumors regular

    Dae

    Joined:
    Apr 30, 2009
    #1
    I noticed that Mac OS X 10.6 sometimes ignores double clicks in the interface. This happens in Finder, less often in Safari, Firefox, iTunes and other applications I use every day. It doesn't happen very often but it's annoying when it does.

    It's not some sort of a hardware issue because I experience the same thing on both of my Macs, MacBook Pro and Mac Pro. It's not my mouse either because as you can see in the screencast below, the OS catches the clicks.

    Note that I filmed the screencast below from the ~15th attempt, because it was actually hard to reproduce the problem twice in a row. As I said, it's not as frequent.

    I'd like to know, does such thing happen on your system?

    (click the image below to watch the video in the new tab/window)
    [​IMG]
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
  3. Dae thread starter macrumors regular

    Dae

    Joined:
    Apr 30, 2009
    #3
    I doubt they care. They ignored the other bug I submitted in February to ADC even though it affects most high-precision mouses. It's such a shame really.
     
  4. ToastyX macrumors regular

    Joined:
    Oct 4, 2005
    #4
    I can easily reproduce it with a slower double-click speed setting. Basically, if you manage to get a third click in the same area before the double-click timeout, it ignores subsequent clicks until you wait for the double-click timeout or click somewhere else. I'm not sure if this is a bug or a misguided attempt to ignore superfluous clicks, but it's annoying behavior. (Edit: it's probably an attempt to detect triple clicks and such getting in the way, so extra clicks get ignored.)

    I find it happens the least if I set the double-click speed one notch left of the fastest setting, but I still manage to trigger it sometimes. If you're a fast double-clicker, maybe setting it to the fastest setting would work better for you, but then it misses double-clicks if you're not fast enough.
     
  5. Hephaestus macrumors 6502

    Joined:
    Apr 4, 2010
    #5
    yeah this happens to me too, the only way for osx to respond is to go into the trackpad settings and set double click speed to max. This fixes the bug of folders not opening but the required speed of double clicks is really fast.
     

Share This Page