MAC won't go to sleep (in my case: OS High Sierra)

Mortandos

macrumors newbie
Original poster
Mar 6, 2020
1
0
Hello, I hope it's ok to post it here because it doesn't seem to be an OS specific issue. There is a whole thread in the Catalina Forum and all across the internet there are issues with Mac's not going to sleep.

I have an older (2011) iMac with High Sierra (Apple support called it "vintage machine", thank you for that!).

Until 2 days ago it worked fine, I could click on the Apple symbol and select "sleep" and it worked. Now it doesn't work anymore, the screen turns black but the computer won't sleep.

I tried all the basics (SRC reset, PRM reset, reboot, checked energy saver settings, checked apps in the activity monitor) and ended up running
  • pmset -g assertions
BackgroundTask 0
ApplePushServiceTask 0
UserIsActive 1
PreventUserIdleDisplaySleep 0
PreventSystemSleep 0
ExternalMedia 1
PreventUserIdleSystemSleep 1
NetworkClientActive 1

The external media is my startup disk (my OS is on an external drive but it has been like that for years).

pid 227(cupsd): [0x0000003400118033] 03:58:57 NetworkClientActive named: "org.cups.cupsd"
pid 69(powerd): [0x0000002700088000] 03:59:09 ExternalMedia named: "com.apple.powermanagement.externalmediamounted"
pid 68(com.tclementdev.timemachineedit): [0x000033cc00018930] 00:18:49 PreventUserIdleSystemSleep named: "com.tclementdev.timemachineeditor.backup"

So here is the Time Machine Editor listed - I have this program for years, how can it now prevent the computer from going to sleep?

And maybe somebody can help me understand what this means:


Details: Delay sleep to run activity.

pid 109(hidd): [0x0000213c00098706] 00:00:00 UserIsActive named: "com.apple.iohideventsystem.queue.tickle.4294968268.3"
Timeout will fire in 180 secs Action=TimeoutActionRelease

And last not least we have this one:

Idle sleep preventers: IODisplayWrangler (but I heard this is "normal"?)

My confusion comes from the fact that I haven't changed anything, haven't run any updates, no new apps, nothing.

Anybody who can help me? Thank you.
 

Bertrude

macrumors member
Aug 2, 2010
93
13
England
I had a similar issue (wouldn't shutdown or restart, showed a black screen with just a movable cursor) a while ago. It would sleep though. It was when a security update didn't install fully.

It turned out to be issues with kernel extensions installed by Steam when I was trying out the remote play option (I think).

Removing these solved my issue.

/Library/Extensions
[Loaded] AmbrosiaAudioSupport.kext (Ambrosia Software, Inc., 4.1.4 - SDK 10.11)
[Loaded] SteamInput.kext (Valve Corporation, 4357.73.42 - SDK 10.13)
[Not Loaded] SteamInput-DS4v1.kext (Valve Corporation, 4357.73.42 - SDK 10.9


Maybe it could be a similar problem in your case too.

You might want to download and run EtreCheck and see what kext files you have loaded - might be one of those?
 
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.