Mac won't sleep when connected to apple monitor in clamshell mode

Discussion in 'MacBook Pro' started by tman1425, Nov 13, 2011.

  1. tman1425, Nov 13, 2011
    Last edited: Nov 15, 2011

    tman1425 macrumors member

    Joined:
    Jun 23, 2010
    #1
    My Macbook Pro would always go to sleep automatically after 30 minutes. However, once I connected it to the apple monitor and used the computer in clamshell mode, it won't go to sleep unless I do it manually.

    Does anyone know why automatically sleep anymore? The apple monitor turns off, but the computer doesn't sleep. None of the setting have been changed either. Any help is appreciated. Thanks in advance.
     
  2. tman1425 thread starter macrumors member

    Joined:
    Jun 23, 2010
    #3
  3. tman1425 thread starter macrumors member

    Joined:
    Jun 23, 2010
    #4
    One last bump to the top. Anyone have any suggestions?:eek:
     
  4. kylepdx macrumors newbie

    Joined:
    Jan 4, 2012
    #5

    I understand, same problem here. I did not have the problem and have not made any changes and have not added any software or changes any utilities. This started happening with my laptop after upgrading to LION.

    It will go to sleep if you disconnect the power AND the Cinema monitor. Otherwise I can not back to the normal sleep after 30 minutes no activity. And disconnecting the power and monitor each time I use it...SUCKS!
     
  5. Frank (Atlanta) macrumors regular

    Joined:
    Oct 29, 2004
    #6
    I, too, am suddenly having this problem. Don't believe any settings have been changed and my MBP was able to automatically go to sleep previously...
     
  6. Frank (Atlanta) macrumors regular

    Joined:
    Oct 29, 2004
    #7
    Found my problem… I had a Garmin ANT+ Agent that wouldn't let my machine sleep. If I disable it, all is fine.
     
  7. applesith macrumors 68020

    applesith

    Joined:
    Jun 11, 2007
    Location:
    Manhattan
    #8
    Same here even when it's just the power is plugged in as well as with monitor.
     

Share This Page