MacBook aluminum runs fine but fails to recognize battery!!!

Discussion in 'MacBook' started by angrymacbookuse, Nov 15, 2008.

  1. angrymacbookuse macrumors newbie

    Joined:
    Nov 15, 2008
    #1
    This is a horrible issue that just popped up. It was not present for the first several weeks of using the new MacBook aluminum. Now, if I unplug the AC adapter the Mac still thinks it is plugged in. It says "power source: power adapter" and it does not indicate that it is running on the battery. Furthermore, my power adapter green/orange lights up intermittently now...sometimes it is just black. I am very worried this is a hardware issue with the macbook itself as even when it is running completely unplugged from the ac, it still thinks it is on ac power.

    I have tried:

    Resetting the SMC
    Repairing permissions, repairing the disk in disk utility.

    Praying to god.

    Does anyone have any other ideas? Thanks very much.
     
  2. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #2
    It might be a flaky battery. I'd have Apple take a look at it.
     
  3. Saganomics macrumors newbie

    Joined:
    Nov 14, 2008
    #3
    Agreed, I would take advantage of your AppleCare.
     
  4. VSMacOne macrumors 601

    VSMacOne

    Joined:
    Oct 18, 2008
    #4
    I definitely understand your frustration... I would try Apple Care. They will honestly assess your situation and recommend the best course of action. There's no need to be angry about this :D
     
  5. youssefm macrumors 6502

    Joined:
    Oct 7, 2008
    #5
    set up a genius bar appointment at your local apple store and see if they can give you a new battery.. if you try a new one and that doesn't work they might swap your macbook out for a new one
     
  6. macbooker15 macrumors 6502

    Joined:
    Jan 19, 2008
    Location:
    Hello! I'm over here!
  7. superczar macrumors newbie

    Joined:
    Nov 13, 2008
    #7
    See this

    http://forums.macrumors.com/showthread.php?t=599506

    Same issue..
    I took the system to a AASP who ran some tests and concluded that it was an issues with the logic board (they also tried a battery swap and that didnt fix it)
    Fortunately for me, the system is still in the DOA period
    Unfortunately, the system was bought in the US and I am in India which makes the whole DOA process rather twisted...
    Keeping my fingers crossed
     

Share This Page