MacBook Can’t Connect to Comcast Assis Modem/Wifi Router


macrumors newbie
Original poster
May 27, 2013
Hi everyone! I have a situation where my MacBook’s wifi can’t connect to my Comcast Xfinity Assis modem/router. I’m at my wits end, and I’m hoping someone on these forums might have some additional ideas or other things I can try.

Here’s what happened: We got Xfinity internet/phone about two months ago. It came with an Assis modem/router. In the two months since we got Comcast, all of our devices (two iPhones, an iPad, a PC and my MacBook) have all connected to the wifi fine. Then, last week, I was using my MacBook when the wifi suddenly dropped and disappeared. Every other device we have still connects to the router normally and receives internet.

So: I reselected my network from the Airport dropdown, and was prompted to enter my password again, which I did. At this point I started getting alternating “Connection Timeout” and “Invalid Password” messages, even though the password is correct. So, here are the steps I’ve taken:

1. I tried restarting my MacBook, and restarting the modem/router. No luck.
2. I went into System Preferences>Networks and tried removing the network, and also went into the keychain and removed the network’s passwords. I restarted and tried logging in again. No luck.
3. I tried the previous step, but before my MacBook restarted I also did a full reset of the Comcast modem/router. No luck.
4. I tried creating a new location in System Preferences>Networks. This time, it connected and the internet worked – for about ten minutes. Then it became slow (dialup speed) before dropping off completely.
5. I created a new admin account, and tried logging into the router. Same as the last step, it connected and the internet worked – for about ten minutes. Then it became slow (dialup speed) before dropping off completely.

I thought perhaps it was an Airport issue, so I went to the Genius Bar. My computer is still under warranty, so they replaced the Airport card. I tried it on the Apple Store wifi, it connected perfectly and got to the internet. The same thing with a café I went to, and my office. The MacBook connects normally to every network I try except for my home network.

When I got back from the Genius Bar with the new Airport card, the computer wouldn’t connect. I tried creating another new location, but to no avail. So, I called Comcast and they told me that it wasn’t their problem, since my phone could connect to the modem, and they’d only help me if I paid for an additional service, which they couldn’t guarantee would solve the problem.

So here I am, at my wits end. I’m not sure what to do, since Apple says it’s not my Airport, and Comcast says it’s not their problem. I’ve been reading forums and come across dozens of people with similar issues: Apple products suddenly losing connectivity to Comcast Xfinity Assis modem/routes. But I haven’t seen any real solutions.

Send help!



macrumors 6502
Feb 2, 2003
Gone to the Beach
Regardless of what Comcast says, it most likely is their problem. Namely the modem/router.
I think the fact that your MacBook works perfectly everywhere else is the key.


macrumors 601
Jun 19, 2007
Plymouth, MN
I agree. I never trust Comcast or other ISP's in general when it comes to their equipment. About the most I will ever lease from Comcast is the modem since buying that makes no sense if I have to switch ISP's and that tends to be reliable. However I refuse to get routing equipment that I cannot control myself. You get leased equipment, you don't get to control it - something I despise. I also like getting routers that are more fully featured and are sold by a more reputable brand but I prefer to own that since it gives me more control over my network.

I doubt the computer is at fault, I think its Comcast's low quality router.


macrumors 603
Feb 13, 2011
Baltimore, Maryland
You could be on the right track in your steps to get that working. You might try repairing permissions after the keychain step...seems to have worked for some.

First, though, try using a different type of encryption in your router's security.


macrumors newbie
Jun 6, 2013
Me too!

I was having this issue also. I logged into the router and went to the admin page ( You will have to log in either using a cable connection or one of the other connected devices. On that page there was an option "Reset Wi-Fi module". I clicked that and then I was able to connect with the MacBook again. Hope that helps!


macrumors newbie
Sep 13, 2013
Quick & dirty solution to this problem-add a wifi router

Well - if one machine plays bad with Comcast's crappy wifi-router-modem...

Just buy a different brand wifi router/hub, and plug it into the Comcast. If it plays nicely with the Comcast, and it probably well, it will also probably play nicely with your MacBook pro. Sort of like a translator or middle man or mediator...