Macbook failing to boot to OSX or from OSX disc

Discussion in 'MacBook' started by Pholk, Apr 10, 2010.

  1. Pholk macrumors newbie

    Joined:
    Apr 10, 2010
    #1
    Hi guys, sorry to come on here and instantly post a help thread but I'm really at the end of my technical knowledge now and don't know what else to try.

    My MacBook 13" which was the current model when I bought it in September '08 decided after a normal shut down to not boot up the next time I tried. It gets as far as loading the grey apple symbol and then gets no further (no loading cog etc...).

    Naturally my first thought was to try to repair from my OSX install disc but when I booted from this the same problem occurred (the grey apple symbol, no further). The disc is definitely recognised by the disc drive and is displayed when I hold the option key on startup. I also tried using a friends OSX disc and the same problem occurred so I'm assuming it can't be the disc.

    I have tried booting in safe mode, single user mode & verbose mode, none of which work although I am able to see where the script gets to in a safe mode boot by using the option that shows this (I can provide this text if it's of any help).

    The weirdest thing is that I have dual-boot set up with Ubuntu on my macbook and I can still boot to ubuntu fine, also all linux live discs I have tried in order to investigate the hard drive have had no trouble booting.

    I have also managed to perform a hardware test successfully (both short and full versions) and this has turned up no problems.

    I have all my data on a time machine back up so that is of no issue, this in mind I have also wiped my mac partition (but not the EFI) and reformatted in HFS+ using Gparted on linux. I thought the disc may have been checking for previously installed versions of OSX and stumbling at this point, hence why I wiped it.

    The leads me to believe that only the EFI could be to blame for the inability to boot to my OSX disc, is there any known way around this?

    Please any suggestions you could make would be of great help
    Thanks in advance

    P.S. I have followed just about every troubleshooting guide around and so simple things such as resetting PRAM & NVRAM have been done. Have also tried removing static or whatever by removing battery/RAM and holding power button for a minute.
     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #2
    I found no official note about resetting EFI but found this thread.

    Try holding down C while booting to boot from the DVD
     
  3. Pholk thread starter macrumors newbie

    Joined:
    Apr 10, 2010
    #3
    Thanks, I'll give the holding down the power button a try even though its only advice for mac minis. Always worth a shot I guess

    I have tried to boot from disc by holding c but alas, still no luck
     

Share This Page