Macbook Pro 13" 2009 display shutting off and only reads 1/2 of ram

Discussion in 'MacBook Pro' started by avw5000, Oct 27, 2012.

  1. avw5000 macrumors newbie

    Joined:
    Jul 27, 2012
    Location:
    Cupertino
    #1
    Hi guys,

    My Macbook pro 13" has been acting weird. Its only reading 1.2 my ram in my computer and the display falls asleep when i turn it on most of the time. I get the the lock screen every once and a while, I have to reset the SMC. Wanted to know if there is a way to fix this. It boots up fine and every indicator is working.

    Thanks
     
  2. T5BRICK macrumors 604

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #2
    Have you recently upgraded anything in the MBP? I'd suspect bad RAM.

    If you havent upgraded anything recently, run AHT extended test, looped, overnight. If you have any hardware issues this should identify them.

    http://forums.macrumors.com/showthread.php?t=1432670
     
  3. avw5000 thread starter macrumors newbie

    Joined:
    Jul 27, 2012
    Location:
    Cupertino
    #3
    Just put in new ram and only half was read. Could it be the logo board
     
  4. T5BRICK macrumors 604

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #4
    It could be several things. Did you try re-seating the new RAM?. Did you put the old RAM(original apple stuff or whatever was working previously) back in to make sure it wasn't just bad memory?
     
  5. avw5000 thread starter macrumors newbie

    Joined:
    Jul 27, 2012
    Location:
    Cupertino
    #5
    Put in original ram and checked reads 1/2

    ----------

    What is re-seating
     

Share This Page