MacBook Pro 13 (A1278) Unibody - No Backlight. LCD works though.

Waldoctg

macrumors newbie
Original poster
Jun 19, 2013
6
0
Hey folks,

I searched the forums and found a couple topics similar to this, but didn't seem to be what my problem was... anyways...

I bought this Macbook Pro off of a kid who said someone dropped it and the LCD stopped working. Hoping I can get some insight to diagnose and fix the problem. Would greatly appreciate it.

Thanks,
Waldoctg
 

nickandre21

macrumors 6502a
Jun 21, 2012
542
1
start by checking if the display cable is connected well, if the issue still occurs you will have to check with another display. Hard to tell what could be the issue for now.
 

Waldoctg

macrumors newbie
Original poster
Jun 19, 2013
6
0
Naw. LCD works. I tested with a flashlight.

The backlight is what does not work. THAT's the real problem...

Anyone?
 

Waldoctg

macrumors newbie
Original poster
Jun 19, 2013
6
0
Lol wait, even though I can see the display with a flashlight?

Like I think it is the backlight inside the MB. Unless the backlight is directly connected to the MB...?
 

sparkyms

macrumors 65816
Feb 22, 2007
1,304
3
Southampton UK
Lol wait, even though I can see the display with a flashlight?

Like I think it is the backlight inside the MB. Unless the backlight is directly connected to the MB...?
Yes, even though you can see the display is *on*, it's likely you will need a new display. As another poster has said the backlight is within the display and it's not something you can replace.

You can decide not to believe us and waste some time by hacking your display to bits looking to change the backlight if you want though.
 

Sanket123

macrumors newbie
Oct 30, 2016
4
0
Hello guys I have an 820-2936 Macbook pro late 2011 13'' i5 A1278


I Have chimes and display but unable to get back light

I can see the image using an flashlight from behind


I have checked the display by connecting to an working screen, but it too doesn't have backlight


board has LP8550 WLED driver


and it doesn't boost output


I have an feedback of at

PPVOUT_SW_LCDBKLT_FB probe 613 12.5v


I am posting all the readings in the pictures



Kindly guide me to help me find what the problem is,

am i supposed to replace LP8550 .


Please guide me


Thanks in advance :)
 

Attachments

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.