MacBook Pro 15’ 2014 Windows 7 Battery “Plugged in, not charging.” Issue

Discussion in 'Windows, Linux & Others on the Mac' started by F-302, Feb 17, 2018.

  1. F-302 macrumors newbie

    Joined:
    Feb 17, 2018
    #1
    I recently installed Windows 7 Pro using the BootCamp utility on my MacBook Pro 15” 2014 laptop. After the installation I checked the battery. It says "99% Available(Plugged in, not charging)". Is this something to be concerned about? And if so how would I fix the issue?

    Any help and/or information would be greatly appreciated.

    Thank you for your time. :)
     
  2. ThunderMasterMind macrumors 6502a

    ThunderMasterMind

    Joined:
    Apr 29, 2016
    #2
    If your charger is indicating that it’s charging by showing the amber light and green when full, it should be fine. It might be Windows acting strange as it loves to do. If it charges fine in macOS and the charger shows that it’s charging fine in Windows, you should be ok.
     
  3. F-302 thread starter macrumors newbie

    Joined:
    Feb 17, 2018
    #3
    The indicator light is working. I’m just not going to worry about it too much. Besides I usually just keep my laptop plugged in all the time anyway.

    Thanks for your help. :)
     
  4. ThunderMasterMind macrumors 6502a

    ThunderMasterMind

    Joined:
    Apr 29, 2016
    #4
    Does the light appear in macOS? If it never shows up, you have a hardware issue that needs to be resolved.
     
  5. F-302, Feb 18, 2018
    Last edited: Feb 18, 2018

    F-302 thread starter macrumors newbie

    Joined:
    Feb 17, 2018
    #5
    Nevermind, I managed to get help from someone outside the forums. The battery is charging now, all I had to do was deplete the battery enough to get the charging process going. It appears to be working fine now. But your help will not go unappreciated. And yes the battery charges in MacOS so it's probably not a hardware issue.

    Thank you for your time. :)
     

Share This Page

4 February 17, 2018