MacBook Pro 15' A1286 Screen HELP!?!

Discussion in 'MacBook Pro' started by DrDankNuggs, Aug 12, 2011.

  1. DrDankNuggs macrumors newbie

    Joined:
    Aug 12, 2011
    #1
    So I have a Macbook Pro 15' Unibody A1286, The screen has gone black but still can faintly be seen by shining a flashlight on the screen. The Apple symbol on the back of the lid is also not lit when it should be! Everything works perfectly when plugged into a external monitor! So I can only assume its a back-lighting issue but cant seem to find the right answer to the problem PLEASE PLEASE PLEASE help
     
  2. res1233 macrumors 65816

    res1233

    Joined:
    Dec 8, 2008
    Location:
    Brooklyn, NY
    #2
    The backlight's dead probably. First, try turning the brightness up with the keyboard. If that doesn't work, then it's in Apple's hands.
     
  3. DrDankNuggs thread starter macrumors newbie

    Joined:
    Aug 12, 2011
    #3
    Yeah its definitely not a brightness issue, what does that mean "the backlight's dead" what part could I replace it with, I would prefer to fix myself if at all possible. I was hoping there was a inverter or something I could swap out, is that at all possible? or no?
     
  4. h00ligan macrumors 68030

    Joined:
    Apr 10, 2003
    Location:
    A hot desert
    #4
  5. DrDankNuggs thread starter macrumors newbie

    Joined:
    Aug 12, 2011
    #5
    Runs the external with out any problem!
    & as far as a screen swap
    I bought 2 identical Macbooks at the same time, I got a light amount of water damage on the underside of one of them which now wont turn on, and the screen on the current one we are talking about died overnight with out any warning signs or reason(the comp is flawless looking)! I swapped the "dead" screen with the one from my water damaged MB but both screens exibited the EXACT same problem, I guess my bottom line is that I have already swapped the screen out even though it was from a water damaged comp it seems the likelihood of both screens displaying the same problem are slim would you agree?
     
  6. DrDankNuggs thread starter macrumors newbie

    Joined:
    Aug 12, 2011
    #6
    [​IMG]

    Just curious that chip on the bottom mid-right side, could that be a inverter or led control of some sort?
     
  7. randomrazr macrumors 65816

    Joined:
    Jan 1, 2011
    #7
    thought LEDS suppose to last for decades! lol
     
  8. DrDankNuggs thread starter macrumors newbie

    Joined:
    Aug 12, 2011
    #8
    Exactly! That's what I thought which is why I'm so confused Comp had no reason to die like it has. External out still works and I am experiencing it with two different monitors i swapped (even though the second one was water damaged!) WTF could this problem be? Ask your peoples people!
     
  9. h00ligan macrumors 68030

    Joined:
    Apr 10, 2003
    Location:
    A hot desert
    #9
    Hmm that is odd. That would leave a connection issue. Replace the cable? I guess that happened with the screen swap. Which would leave the logic board connector as bad I would think. :/. I assume you did a pmu reset to begin with right?
     
  10. DrDankNuggs thread starter macrumors newbie

    Joined:
    Aug 12, 2011
    #10
    Yeah, I did that and one other reset before. The screen that i have on now was from my other identical MB that got water damage on the bottom of it, so it could be damaged too. I just thought the chances slim, ya know having the same exact problem in each screen! I would really like to fix this cause that would make a couple paper weights that cost over 3 grand!
     

Share This Page