MacBook Pro 15 Firewire unable to list firewire devices and takes 5-6 Start up

Discussion in 'MacBook Pro' started by NZLou, Feb 16, 2009.

  1. NZLou macrumors newbie

    Joined:
    Feb 16, 2009
    #1
    I currently have my second MBP that I got from Macmall and both in a matter of two weeks have had similar issues. The first I managed to get returned and replaced, that is a seperate and complicated story in and of itself. This particular issue started with a boot up sequence that was taking about 5-6 mins. After going through the drill with Applecare thought I could restore using Time Machine. That's when I found out that the FW400 port no longer worked to power my Oyen Digital 250G FW drive. Any thoughts as to what might be the problem? This is my second MBP and Oyen Digital FW drive. I had them both replaced!
     
  2. pscherdell macrumors newbie

    Joined:
    Feb 28, 2009
    #2
    Firewire and Startup on Macbook problems.

    Same problem and can't find an answer. Macbook Pro Intel Core 2 Duo. 4-5 minutes to startup and the Firewire Bus says - Warning: Unable to list FireWire devices. Reinstalled Leopard, no luck. Apple Hardware Test - Passed.

    Anybody?
     
  3. morrowless macrumors newbie

    Joined:
    Mar 23, 2009
    #3

    Same problem...one possible solution I read mentioned to reset the PRAM, but my battery won't hold a charge enough to boot with being plugged in.

    System profiler was showing that my firewire ports cold go up to 800 MB/S but then I went a deleted firewire as a network connection and now profiler says unable to list firewire devices.

    Further, I recently reinstalled OSX. Right off the bat I connected a lexar firewire 400 cf card reader and an owc 500gb firewire 800 drive. Neither was mounting, then I unplugged the cf reader and all of a sudden the owc drive mounted. I immediately started to copy about 30GB of pictures to the owc drive and part way through it unmounted itself.

    Now I'm trying to troubleshoot all the while debating ordering an ExpressCard firewire adapter or just getting a new macbook pro.
     
  4. Guy Mancuso macrumors 6502a

    Joined:
    Mar 28, 2009
    #4
    Believe it or not I have had a lot of issues with bad cables. At least try a different one. I will tell you though with all the USB ports and mini display ports in use i have had Firewire start up issues as well with my Drobo. My thinking is this there just is not enough power going to all those connections at boot time. Try this pull everything off except the firewire and it will most likely boot up with it. Also put the USB stuff on a powered hub. Not enough power there as well. But finally my last solution was putting my external drive on a e-sata express card and now the only Firewire 800 is the Drobo and I am able to boot with everything attached. Bottom line isI just don't think enough power is being sent to the connections on boot. Now granted I have a lot of stuff connected but this is what has been going on the last two weeks since I have received the MPB. I have a 30 inch display thrown in the mix as well. But try pulling some connections off than work up until you figure what you can connect and what you can't on boot up. But do go powered on the USB stuff that helps a lot right off the bat.
     
  5. hungerf9 macrumors newbie

    Joined:
    Aug 11, 2009
    #5
    Same Problem

    I'm having the same problem on my 15" MBP: non-functioning fire wire ports and the long boot up time.

    Still looking for a solution. Have any of you had any luck?
     
  6. jackfierce macrumors newbie

    Joined:
    Sep 3, 2009
    #6
    Same problem here.
    Firewire external wont mount or be recognized. "Warning: Unable to list FireWire devices." in System Profiler. Light on my external indicates functional plug and cable (the drive and firewire cables works on every computer except my Macbook pro). I tried resetting the PRAM... tried unplugging everything and letting it sit... tried holding the power button for 5-10 seconds...

    Any other ideas? Getting desperate.
    There must be a solution!
     
  7. fischerle macrumors newbie

    Joined:
    May 28, 2008
    #7
    Same problem, no one at Apple can help

    this is really frustrating. Slow boot up time, no firewire access. Completely erased and clean-installed snow leopard. still no change. so it has to be a firmware issue but i see no news about an update for this. Any help would be MUCH appreciated.
     
  8. goMac macrumors 603

    Joined:
    Apr 15, 2004
    #8
    Could potentially be a bad Firewire controller. Usually this sort of thing happens when the computer sits there waiting to see if there are any Firewire devices available, so it sits there just hitting up the Firewire bus while it's booting, but the Firewire bus sends back garbage. Similar things happen with SATA controller/ribbon issues.

    But that's just my armchair diagnosis. Take it to a genius.
     
  9. macthemikey macrumors newbie

    Joined:
    Mar 19, 2010
    #9
    macbook pro 17" firewire and sleep issue

    Just purchased a used 17" Macbook pro core 2 duo. 2006 model. Before purchasing I shut it down and re-started - 45 seconds. Put it to sleep - woke it up - flawless. Closed the lid, opened it - it comes up right away. Plugged in an external drive into all usb ports and then firewire ports - all worked nicely. Machine is in excellent shape. Got it home and did a clean install of Leopard 10.5.6 to make it my own. Now, it takes 5 minutes to boot up.... it sleeps and I cannot wake it so I have to do a hard re-start - the firewire ports are no longer working. WTF? Took it to Apple Store, left it , they ran some overnight hyper-extended test - they tell me that everything is working fine with the exception that they cannot see what's going on when during startup the screen goes blue and sits there for a while. I have seen other posts here with some similar issues. How can we resolve this? Any suggestions? It is totally frustrating. Thanks.

    Michael.
     
  10. Benja.rb macrumors newbie

    Joined:
    Mar 27, 2010
    #10
  11. kgeier82 macrumors 65816

    Joined:
    Feb 18, 2008
    #11
    I have a FW800/400/usb2 Rosewill enclosure with a 500GB seagate in it.

    It used to be a time machine drive, but I have since stopped using it all together. No matter what I do, the FW somehow shuts off part way through a TM backup. If I try to just use the drive as a storage device, it also shuts down, unmounts randomly, and is just not useable.

    I am on my second 2.26 MBP 13" now, the first I owned several months ago, and had the same issue.

    What gives.
     
  12. cube macrumors G4

    Joined:
    May 10, 2004
    #12
    Doing an SMC reset fixed my FireWire. Zapping the PRAM had not been enough.
     

Share This Page