MacBook pro a1278 2009

Discussion in 'MacBook Pro' started by Los157, Aug 11, 2011.

  1. Los157 macrumors newbie

    Joined:
    Aug 11, 2011
    #1
    I have a MacBook pro a1278 13 inches 2009. I'm having a problem the laptop wont turn on. When I plug the charger in it turns green and then orange for charging. So all that means that the smc gets recognition and let's the battery charge I also click on the battery meter and it says the battery is charging. But when I press the power button it doesn't do nothing. I reseted the smc nothing. So now I wanna take a multimeter to the board but I have never used one. So maybe you guys could help with that. Or I read somewhere on this forum about jumping the logic board on by touching two pads. Can you guys give me some pics? Also what setting should I use on the multimeter? And what points should I test?
     
  2. 87am macrumors regular

    Joined:
    Feb 27, 2011
  3. xlii macrumors 68000

    xlii

    Joined:
    Sep 19, 2006
    Location:
    Millis, Massachusetts
    #3
    What this guy said... plus a 2009 model is still on Applecare if you bought it.
     
  4. Los157 thread starter macrumors newbie

    Joined:
    Aug 11, 2011
    #4
    That's the problem I bought it on eBay and it doesn't have AppleCare.
     
  5. GuitarG20 macrumors 65816

    GuitarG20

    Joined:
    Jun 3, 2011
    #5
    Genius Bar is still by far your best bet as to figuring out what's wrong with it.
     
  6. Los157 thread starter macrumors newbie

    Joined:
    Aug 11, 2011
    #6
    Anybody have had this problem and have any solution?
     
  7. hammten macrumors regular

    Joined:
    Jul 7, 2008
    #7
    Did it previously have damage such as water spills? Also how long ago did you purchase it, you might want to contact the seller, but i agree with genious bar.
     
  8. Los157 thread starter macrumors newbie

    Joined:
    Aug 11, 2011
  9. Los157 thread starter macrumors newbie

    Joined:
    Aug 11, 2011
    #9
    Update: I actually got the computer to fully charge. The MagSafe turned green. I pressed the battery indicator Which said the battery was full.
     
  10. accessoriesguy macrumors 6502a

    Joined:
    Jul 8, 2011
    #10
    so what did you do? did you just press the battery indicator? or what?
     
  11. Los157 thread starter macrumors newbie

    Joined:
    Aug 11, 2011
    #11
    No I just plugged the magsafe in and charged the computer. The computer charges but it just doesnt turn on.
     

Share This Page